Lag / Freez when streaming to Apple TV


Recommended Posts

Hi folks

 

I'm running a fresh install of the Debian branch with 5.X Kernel branch.

I got 2 new 4TB HD setup with MDAM in RAID 1 mode to store my photo and documents with Syncloud also running on the HELIOS64.

I Got also a 2,5 Sata drive mount and share via Samba to my home network.

My Helios64 is plugged via the 2,5GB Ethernet port directly to my Router on the 2,5GB port. I didn't fix the hardware bug, but if I understood it's not necessary in my case ( 2,5GB Ethernet on a 2,5GB Ethernet Router)

 

My problem is that on the same router I got an Apple TV (on ethernet port too) with Infuse app on IT.

And there is the problem I got big MKV files that play fine for most of them, but all MP4 files lag and freez !!!

 

Before getting the Helios NAS, this same SATA drive was plug via USB2 port of my router but never freeze, only a delay to cache the video file but after everything played fine.

Is that a known problem ?

Is there a way to check the health of my SATA Drive ?

I've read on the wiki that there is an TX offload setting that can be disable? ethtool -K eth1 ??? If I understood it's to avoid that the CPU decode the file and let that job to the network bus.

 

Do you have any recommandation that I should follow to sort this out ?

Thank in advance

 

PS: I'm a rookie an linux world but I enjoy it a lot so be kind with command and

Edited by Dakey86
Link to post
Share on other sites
  • Dakey86 changed the title to Lag / Freez when streaming to Apple TV
Armbian is a community driven open source project. Do you like to contribute your code?

Maybe check if on Infuse app has some settings to tweak the caching.

 

Did you check on Helios64 if something is happening while streaming those MP4 file ? (use dmesg -w to see if anything wrong happen).

 

You could also try with the 1GbE (eth0) interface this way you can narrow down the issue.

Link to post
Share on other sites