Jump to content

[Invalid] - I2C NanoPI Neo Plus2, doesn't work


Recommended Posts

gpio load i2c
modprobe: FATAL: Module i2c-sunxi not found in directory /lib/modules/4.14.111

By looking at example of WiringPI (for Raspberry), I tried the above command, result is shown.


I'm newbie, so I need to figure out how to send commands via i2c to an external device.

But first, how do I even enable i2c on Neo Plus2? Or is it enabled on default? I saw on this forum suggestion to add:

a line "overlays=i2c0 i2c1" in /boot/armbianEnv.txt

However, my boot directory is full, so and I get error 514 whenever I try to add anything to armbianEnv.txt (which is empty)

Here's disk usage:



I added 10K pull up resistors between Pin #1 SYS_3.3V and  Pin #3 I2C0_SDA / GPIOA12 and Pin #5 I2C0_SCL / GPIOA11.


Result of i2cdetects:



However, when I tried to output from I2C0_SCL pin the following:

 sudo i2cset -y 3 0x30 255 (writes the byte value 255 to the I2C device at address 30 hex on the i2c-3 bus)

And I was checking with scope the pins I2C0_SDA and I2C0_SCL, and nothing was shown there, other than 3.3V.


Also, I'm not sure where bus 3 is, I mean don't pins I2C0_SDA and I2C0_SC correspond bus to i2c-3? There are no other pins for other I2c buses...

Link to comment
Share on other sites

Your issue report is not a valid bug report per the Armbian bug reporting instructions (https://www.armbian.com/bugs).  With limited resources the Armbian project is only able to spend time on issues where all the requested information has been provided and for only the boards/images/software that are supported.  Your report is invalid for one or more of the following reasons (non-exhaustive list):


  • it is for an unsupported board or image (CSC/EOS/WIP/edge)
  • it is for software that is not supported (such as userspace modules installed on top of the core operating system)
  • it has been logged in the wrong forum (for example requests for help that are not actual bug reports)
  • it lacks requested data (armbianmonitor output)
  • it could have been easily solved by a quick search and/or reading documentation


Please review what you have submitted and the bug logging instructions (https://www.armbian.com/bugs) and either add the required information or open a new topic in the correct forum (such as Common issues / peer to peer technical support or General chit chat)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines