Rupa Pyramid A5x - Android TV Box HDMI sound missing.


 Share

1 1

Recommended Posts

Hi everyone, long term lurker to this site, however I see a whole trend in S905X Android TV boxes with sound issues. As far as I understand the SPDIF and AV ports are not supported with Armbian, however, HDMI Audio is I think. My box Rupa Pyramid A5x with the Amlogic S905X CPU boots great, followed the guides to the letter. Graphics are great, performance is as expected, 4K video is a little struggle sometimes, I suspect this is Firefox though, I actually use this same box for many years as a headless Plex/Docker server and it was amazing for this! I mean really really good. 4/5/6 steams at the same time to TVs, iPads, phones and then some more!.

 

The issue I am having is related to HDMI sound, many posts about this, but to real resolution. Is HDMI sound even supported on this CPU?. The Arabian UI sound section shows output in the volume bars, bit nothing works from the display sound wise, I tested 3 monitors with build in speakers now, nothing, tested new HDMI cables as well, still no sound. 

 

I am using Armbian_20.10_Arm-64_bullseye_current_5.9.0_desktop.img as my install with the meson-gxbb-nexbox-a95x.dtb file and have also tested meson-gxl-s905x-p212.dtb without success. Could my issues be related to Armbian 5.9? does anyone know if past version had HDMI sound?. I really want to use this box as a mini desktop, this one missing step is really annoying :)

 

Thanks in advance, 

W

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

5 hours ago, Logicpro8_user said:

Hi everyone, long term lurker to this site, however I see a whole trend in S905X Android TV boxes with sound issues. As far as I understand the SPDIF and AV ports are not supported with Armbian, however, HDMI Audio is I think. My box Rupa Pyramid A5x with the Amlogic S905X CPU boots great, followed the guides to the letter. Graphics are great, performance is as expected, 4K video is a little struggle sometimes, I suspect this is Firefox though, I actually use this same box for many years as a headless Plex/Docker server and it was amazing for this! I mean really really good. 4/5/6 steams at the same time to TVs, iPads, phones and then some more!.

 

The issue I am having is related to HDMI sound, many posts about this, but to real resolution. Is HDMI sound even supported on this CPU?. The Arabian UI sound section shows output in the volume bars, bit nothing works from the display sound wise, I tested 3 monitors with build in speakers now, nothing, tested new HDMI cables as well, still no sound. 

 

I am using Armbian_20.10_Arm-64_bullseye_current_5.9.0_desktop.img as my install with the meson-gxbb-nexbox-a95x.dtb file and have also tested meson-gxl-s905x-p212.dtb without success. Could my issues be related to Armbian 5.9? does anyone know if past version had HDMI sound?. I really want to use this box as a mini desktop, this one missing step is really annoying :)

 

Thanks in advance, 

W

 

Hi! 

 

Did you check alsamixer?

Had the same problem on my S905W box. 

 

I just needed to alternate between I2S / SPDIF and it worked like magic 

 

If you have any doubts, post an image of how your alsamixer screen looks like

Link to post
Share on other sites

 Share

1 1