Jump to content
  • 0

[Invalid] - Rock64 HDMI video scan lines



After shelving my Rock 64 I dusted it off and downloaded the latest desktop image with Ubuntu Focal. The latest OS has video artifacts that the older OS did not. I can only describe the issue as "scan lines," but they are random black bars that appear through out the entire screen (as if WiFi is interrupting the signal only there's no WiFi on the device). I would like to know the best way to bisect the issue as I'm fully capable of cloning the repo, building the image, loading the image and testing it out but if there are pointers to simplify the process I'd love to hear. Hoping to give back since this is a community supported board. Thanks.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Armbian Linux community supported weekly builds download

  • 0

Your issue report is not a valid bug report per the Armbian bug reporting instructions (https://www.armbian.com/bugs).  With limited resources the Armbian project is only able to spend time on issues where all the requested information has been provided and for only the boards/images/software that are supported.  Your report is invalid for one or more of the following reasons (non-exhaustive list):


  • it is for an unsupported board or image (CSC/EOS/WIP/edge)
  • it is for software that is not supported (such as userspace modules installed on top of the core operating system)
  • it has been logged in the wrong forum (for example requests for help that are not actual bug reports)
  • it lacks requested data (armbianmonitor output)
  • it could have been easily solved by a quick search and/or reading documentation


Please review what you have submitted and the bug logging instructions (https://www.armbian.com/bugs) and either add the required information or open a new topic in the correct forum (such as Common issues / peer to peer technical support or General chit chat)

Link to comment
Share on other sites

  • 0

More news, I think this could be a u-boot issue. I have seen some u-boot related changes in the Armbian changelog at https://docs.armbian.com/Release_Changelog/

Thank you for moving to Jira and keeping such good track of completed tasks -- this gives me much more insight into what has changed and when.


Here's how I believe it's a u-boot issue:

1. I started with an older Armbian image I have: Armbian_5.91_Rock64_Debian_buster_default_4.4.184_desktop.img

2. I copied several Linux kernels onto this SD card and updated the /boot/Image and /boot/uInitrd and /boot/dtb symlinks to load different kernels.


All kernels I tried did not produce any black bars on the HDMI output.


The kernels tested were

- 4.4.184 from Armbian_5.91_Rock64_Debian_buster_default_4.4.184_desktop.img

- 4.4.213 from Armbian_21.08.1_Rock64_buster_legacy_4.4.213_xfce_desktop.img

- 5.10.60 from Armbian_21.08.1_Rock64_bullseye_current_5.10.60.img

- 5.13.12 from Armbian_21.08.1_Rock64_hirsute_edge_5.13.12.img


Next I will load the Armbian 21.08.1 images without any changes to SD card to verify that they are all affected before inspecting u-boot.

Link to comment
Share on other sites

  • 0

More news, this is not u-boot issue. I git cloned current armbian build from github.com and compiled kernel+bootloader. This resulted in `output/debs/linux-u-boot-current-rock64_21.11.0-trunk_arm64.deb` I inspected this file and can see there is no `preinst` or `postinst` files so manual update of the bootloader is necessary (without doing more search). Looking at the `/usr/lib/u-boot/platform_install.sh` script and the files in the *.deb I can see the relevant dd commands that are needed to update the bootloader.


With `Armbian_5.91_Rock64_Debian_buster_default_4.4.184_desktop.img` as the image written to SD card, I wrote the newly compiled bootloader and I restarted the rock64. It did not display any HDMI/video artifacts.

To further exclude u-boot being problematic, I wrote `Armbian_21.08.1_Rock64_bullseye_current_5.10.60.img` to SD card then extracted the bootloaded from Armbian 5.91 and wrote it to SD card. This did not fix the HDMI artifacts.


Now time to investigate which package is causing the issue :( This will probably take a long time.

Link to comment
Share on other sites

  • 0

So the issue might be in the kernel after all which is good. I found this by playing with armbian-config utility to change the kernel and u-boot versions. 4.4.x is ok but 5.10, 5.13, and 5.14 exhibit the behavior. I'm not sure why my older tests did not exhibit the HDMI artifacts. I've been trying to compile old versions for rock64 using armbian build but it seems that is quite challenging because gcc-linaro is not found because the old torrent file is not longer available (branch v20.08) and in a different branch (v20.05) u-boot fails to compile because of an error (/usr/include/libfdt_env.h:71:30: error: conflicting types for ‘fdt64_t’).


I think it's time to ask in the peer to peer section

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...