mxq pro 4k 5g


andybo
 Share

1 1

Recommended Posts

Hello,

i have buy a tv box mxq pro 4k 5g "8gb ram and 128gb nand".

In a few years i have buy the mxq pro 4k without 5g and i have use the dtb file the meson-gxl-s905w-p281.dtb

Then i have write the armbian image with dd to the sd card.

In the /boot directory i have edit the boot.cmd file with following:

boot.cmd

 

The most important settings:

setenv prefix "boot/

setenv fdtfile "dtb/amlogic/meson-gxl-s905w-p281.dtb"

 

Then i have build the boot.scr with this command:

mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr

 

Then i have insert the sd card in the sd card slot from the tv box, push the button in SPDIF for 10 seconds, and then the mxq pro starts, but the linux system didnt start.

 

Now i would know, why the box didnt start?

Must i use a other dtb file?

 

I have build the armbian image from source with following:

lepotato

debian bullseye

minimal image without desktop

The kernel i didnt change

 

Thanks in advance

Edited by andybo
Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Hi thank you for answer.

I have read the Link.

If im home i will download the balbes Image and write it to the SD Card.

How to configure Files stay also in the Link.:thumbup:

Balbes has stopped the work for the TV boxes. Only updates for the os, can use from debian or Ubuntu.

Kernel Updates can only used if everyone Compiled it from the source.

Gives it a link how  explaine  compile the kernel?

Edited by andybo
Link to post
Share on other sites

The Box run now with armbian.

I have write the Multitool Image for rk3229  to SD Card.

The armbian Image i have Copy in the Image folder.

Then i have start the Box with the SD Card inside.

Multitool Starts, then i have done a Backup from the emmc.

After that i have write the armbian image to emmc.

Then shutdown the Box.

Now the Box Starts with armbian:)

The Box have 8gb emmc and 8gb DDR3, but only 1gb DDR3 the system ist knowing.

Whats wrong?

Link to post
Share on other sites

@andybo your box does not have 8Gbyte of ddr3.  The rk 32xx cpus only support a max of 4Gbyte, so there is no manufacturer that would install more memory than could be used.  I suspect what you have thought was 8Gbyte is really 8Gbit which equals the reported 1Gbyte.

Link to post
Share on other sites

 Share

1 1