2 2
jstan

Analog audio output low volume with mpd server (orange pi pc)

Recommended Posts

Hello,

 

I have problem with mpd server and sound volume in mpd. When I set volume to max in alsamixer and in mpd  (mpc volume 100) sound is very quiet. When I run mplayer with the same mp3 and alsamixer settings the sound is very loud. I tried mixer_type set to software and hardware in mpd.conf but with no effect. I think the problem is with allwinner audiocodec because when I use usb sound card everything works as expected ( them same sound levels in mpd and mplayer ).

 

Is there any trick to solve this?

 

Share this post


Link to post
Share on other sites

PUSH

 

same problem for me

 

using Armbian 5.23 jesse server on OPI PC Plus and getting the same issue. Volume is so quiet, that the analog to bluetooth transmitter doesnt recognize the sound...

 

any help?

Share this post


Link to post
Share on other sites

 

Exactly this was my intention and I followed the first guide. First I installed the system cleanly and after that I installed apt-get install mpd mpc ncmpc with its all of thousands dependencies.

 

After that I created the playlists exactly as described and the first difference was, that i the path was not correct (/var/lib/mpd/music/radio.pls instead of /var/lib/music/radio.pls).

 

After I created the pls at the correct place I found out that mpd must be started manually and after that a mpc load radio.pls and mpc play works perfectly.

 

BUT sound is too quiet. I tried three different in-ear headphones and also a analog to bluetooth sender and my denon receiver. sound is very very quiet overall. I tried to set alsamixer volume to the highest and also set the volume in script.bin from 31 to 100 - but no change.

 

Changed the renderer to software in /etc/mpd.conf but then I can change volume in mpc so, that 100% is as quiet as before and everything below is much quieter....

Share this post


Link to post
Share on other sites
this helped great

 

 File: /etc/asound.conf:                                       

 

    pcm.!default {

        type hw

        card 0

        device 0

      }

      ctl.!default {

        type hw

        card 0

      }

 

pcm.louder {

        type plug

        slave.pcm "dmix"

        ttable.0.0 3.0

        ttable.1.1 3.0

}

 

pcm.!default "louder"

Share this post


Link to post
Share on other sites

Hi

Looking at the orange PI PC schematic

Analogue audio output is made with a 4.7µF capacitor in serial with a 30K resistor

This seems odd

Either capacitor or resistor is too big .

In all cases it need a high input impedance load

and should not work with any kind of earphone.

On the orange PI plus an amplifier is added and an earphone should work.

HTH

Share this post


Link to post
Share on other sites

Hi

Looking at the orange PI PC schematic

Analogue audio output is made with a 4.7µF capacitor in serial with a 30K resistor

This seems odd

Either capacitor or resistor is too big .

In all cases it need a high input impedance load

and should not work with any kind of earphone.

On the orange PI plus an amplifier is added and an earphone should work.

HTH

 

on my opi pc plus sound volume is now as loud as on my samsung smartphone... perhaps there is a other schematic on the opi PC PLUS...

Share this post


Link to post
Share on other sites

I've solved this problem. I add  following lines to /etc/mpd.conf:

decoder {

plugin "mad"

enabled "no"

}

 

Works also great, but where is it for? What enables / Disables it?

 

Thank you :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
2 2