Failing to install NUT


Carlos Hartmann
 Share

1 1

Recommended Posts

Hi!

 

I'm trying to install NUT because I connected a UPS device. I'd like to get it working so that the server is shutdown safely when there is a power interruption and that I get an e-mail notifying me as soon as there is an interruption.

 

Already after installing via 

sudo apt install nut nut-client nut-server

 

I get the following warnings:

Setting up nut-client (2.7.4-8) ...
Job for nut-monitor.service failed because the service did not take the steps required by its unit configuration.
See "systemctl status nut-monitor.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nut-client, action "restart" failed.
● nut-monitor.service - Network UPS Tools - power device monitor and shutdown controller
   Loaded: loaded (/lib/systemd/system/nut-monitor.service; enabled; vendor preset: enabled)
   Active: failed (Result: protocol) since Sat 2021-12-11 16:33:11 CET; 24ms ago
  Process: 24611 ExecStart=/sbin/upsmon (code=exited, status=0/SUCCESS)

Dec 11 16:33:11 helios64 systemd[1]: Starting Network UPS Tools - power device monitor and shutdown controller...
Dec 11 16:33:11 helios64 upsmon[24611]: upsmon disabled, please adjust the configuration to your needs
Dec 11 16:33:11 helios64 upsmon[24611]: Then set MODE to a suitable value in /etc/nut/nut.conf to enable it
Dec 11 16:33:11 helios64 systemd[1]: nut-monitor.service: Can't open PID file /run/nut/upsmon.pid (yet?) after start: No such file or directory
Dec 11 16:33:11 helios64 systemd[1]: nut-monitor.service: Failed with result 'protocol'.
Dec 11 16:33:11 helios64 systemd[1]: Failed to start Network UPS Tools - power device monitor and shutdown controller.

 

And the output of systemctl status nut-monitor.service is:

 

● nut-monitor.service - Network UPS Tools - power device monitor and shutdown controller
   Loaded: loaded (/lib/systemd/system/nut-monitor.service; enabled; vendor preset: enabled)
   Active: failed (Result: protocol) since Sat 2021-12-11 16:33:11 CET; 5min ago

Dec 11 16:33:11 helios64 upsmon[24611]: upsmon disabled, please adjust the configuration to your needs
Dec 11 16:33:11 helios64 upsmon[24611]: Then set MODE to a suitable value in /etc/nut/nut.conf to enable it
Dec 11 16:33:11 helios64 systemd[1]: nut-monitor.service: Can't open PID file /run/nut/upsmon.pid (yet?) after start: No such file or directory
Dec 11 16:33:11 helios64 systemd[1]: nut-monitor.service: Failed with result 'protocol'.
Dec 11 16:33:11 helios64 systemd[1]: Failed to start Network UPS Tools - power device monitor and shutdown controller.
Dec 11 16:33:12 helios64 systemd[1]: /lib/systemd/system/nut-monitor.service:6: PIDFile= references path below legacy directory /var/run/, updat
Dec 11 16:33:13 helios64 systemd[1]: /lib/systemd/system/nut-monitor.service:6: PIDFile= references path below legacy directory /var/run/, updat
Dec 11 16:33:13 helios64 systemd[1]: /lib/systemd/system/nut-monitor.service:6: PIDFile= references path below legacy directory /var/run/, updat
Dec 11 16:33:14 helios64 systemd[1]: /lib/systemd/system/nut-monitor.service:6: PIDFile= references path below legacy directory /var/run/, updat
Dec 11 16:33:15 helios64 systemd[1]: /lib/systemd/system/nut-monitor.service:6: PIDFile= references path below legacy directory /var/run/, updat

 

And I can't use stuf like nut-scanner so the packages aren't completely installed. Googling around just confused me because it's not even clear to me where the mistake is or how to fix it.

 

Any help is appreciated, even if just in form of "go there and ask them".

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

 Share

1 1