Jump to content

Question about USB wi-fi adapters + Amlogic CPUs


lauro
 Share

Recommended Posts

Hello. I'm a newbie, so bear with me here.

 

I managed to install Armbian on a TV box with the Amlogic s905w CPU. Everything seems to be working fine except for the wi-fi, which is expected based on what I've read on the forum.

 

I had a USB wi-fi adapter with me so I tried to use that as an alternative but it doesn't seem to work no matter what I do.

 

My question is very straightforward actually, and probably a dumb one but it doesn't hurt to ask.

 

When we say wi-fi doesn't work on Amlogic CPUs, we're talking about Armbian recognizing their built-in wifi card, right?

 

If I use something external to that it should be able to work regardless of the processor? Or are we talking about two things that can't be separated?

Link to comment
Share on other sites

Donate and support the project!

An external usb wifi adapter should generally work.  The key being that the linux kernal has the required driver/module to support that usb driver.  Generally any common wifi adapter will have linux kernel support.  I would avoid trying to get the cheapest usb wifi adapter you can find, as those are more likely in my experience to not have linux support.

 

Making sure that I am providing a complete answer to your question, the lack of support for the internal wifi on TV boxes is unrelated to support for any specific usb wifi adapter.

Link to comment
Share on other sites

On 2/11/2022 at 10:37 AM, SteeMan said:

An external usb wifi adapter should generally work.  The key being that the linux kernal has the required driver/module to support that usb driver.  Generally any common wifi adapter will have linux kernel support.  I would avoid trying to get the cheapest usb wifi adapter you can find, as those are more likely in my experience to not have linux support.

 

Making sure that I am providing a complete answer to your question, the lack of support for the internal wifi on TV boxes is unrelated to support for any specific usb wifi adapter.

Thanks for the answer, man! It clarified things a lot.

 

Just as a general update about my main problem that might help someone in the future, I insisted a little bit more and was able to solve my problem.

 

I had to manually build the driver because the built-in one wasn't working thanks to some calibration functions. Not at all related to Armbian but the Linux kernel as a whole.

 

My adapter has the mt7601u chip. It worked fine after these steps: https://askubuntu.com/a/1207160

Link to comment
Share on other sites

 Share

×
×
  • Create New...