Jump to content
  • 0

Public Key for repository not recognized


natsbar
 Share

Question

So, first of all, pretty much a newbie here. I'm trying to add protonvpn to my HC4. I was able to do it with Ubuntu Mate (from the HC4 webpage) on the same hardware, so I'm pretty sure it's possible on Armbian. To be fair, the ProtonVPN website says that raspbian is not supported (and I assume they meant to say ARM) but I have been able to get it to work on Mate, and the problem on Armbian seems to be the Public Key and nothing else. After installation, the app will start, but won't work, so some successful compiling for ARM seems to be happening.

 

What I did:

- Downloaded the deb file for Debian based stable release

- Tried GDebi and Apt, but dpkg worked (relatively) better

- sudo apt update resulted in:

 

Err:12 https://repo.protonvpn.com/debian unstable InRelease

The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 71EB474019940E11
Reading package lists... Done
W: GPG error: https://repo.protonvpn.com/debian unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 71EB474019940E11
E: The repository 'https://repo.protonvpn.com/debian unstable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'https://repo.protonvpn.com/debian stable InRelease' does not seem to provide it (sources.list entry misspelt?)
W: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'https://repo.protonvpn.com/debian stable InRelease' does not seem to provide it (sources.list entry misspelt?)

 

- I've tried fixing it using suggestion from https://askubuntu.com/questions/13065/how-do-i-fix-the-gpg-error-no-pubkey being:

 

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 71EB474019940E11

gpg --export --armor 71EB474019940E11 | sudo apt-key add -

 

- I retried using a keyserver from MIT and the Public Key file downloaded from the ProtonVPN website (took a few tries to get the syntax right).

 

But every sudo apt update has the same result.

 

Ready to provide more information as needed. Also ready to hear that this is either a bug or a feature.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...