Jump to content
  • 0

V4L2 error after updating kernel to 5.15 from 5.10





Hi all


After update kernel from 5.10.60 to 5.15 or 5.16 on my Orange PI PC+ MJPEG-Streamer throws:


libv4l2: error turning on stream: Cannot allocate memory

motion throws:


[1:ml1] [ERR] [VID] v4l2_set_mmap: Error starting stream. VIDIOC_STREAMON: Cannot allocate memory


I tried to decrease resolution - even 320x240 not helps.

Rolling back to 5.10.60 helps, but it's not very sustainable solution.


Are there any known solution for 5.15-5.16?


Today checked kernel 5.15.43-sunxi and 5.17.11-sunxi - same issue


baal@3dprinter:~$ mjpg_streamer -i "input_uvc.so -f 5 -d $(ls -1 /dev/video[1-9] | head -1) -r SVGA -n" -o output_http.so
MJPG Streamer Version: git rev: 310b29f4a94c46652b20c4b7b6e5cf24e532af39
 i: Using V4L2 device.: /dev/video1
 i: Desired Resolution: 800 x 600
 i: Frames Per Second.: 5
 i: Format............: JPEG
 i: TV-Norm...........: DEFAULT
 i: FPS coerced ......: from 5 to 30
 o: www-folder-path......: disabled
 o: HTTP TCP port........: 8080
 o: HTTP Listen Address..: (null)
 o: username:password....: disabled
 o: commands.............: enabled
libv4l2: error turning on stream: Cannot allocate memory
Unable to start capture: Cannot allocate memory
 i: Can't enable video in first time
 i: cleaning up resources allocated by input thread
^Csetting signal to stop
force cancellation of threads and cleanup resources
 o: cleaning up resources allocated by server thread #00


Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Help Armbian team helping you!

  • 0

[    0.000000] cma: Reserved 128 MiB at 0x75c00000

128MiB cma is probably not sufficient according to here:


Decoding H.264/H.265 videos can require a large amount of CMA memory,  so it is recommended to set a large CMA pool, e.g. using the cma kernel  command line parameter. For instance, 256 MiB should be enough to  decode 1080p H.264 videos: cma=256M.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...