Jump to content
  • 0

ROCK64 and USB SATA SSD not detected [SOLVED]


sgjava
 Share

Question

Running latest Jammy image and trying to attach USB to SATA 3 SSD. I tried two different USB 3 to SATA adapters and they both show up in lsusb:

 

Bus 005 Device 002: ID 2109:0711 VIA Labs, Inc. VL711 SATA 6Gb/s bridge

 

sudo fdisk -l doesn't show drive, but I can plug into my desktop and it mounts disk.

 

Could be related to https://github.com/MichaIng/DietPi/issues/5378

Edited by sgjava
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Posted (edited)

Answering my own question here for other folks. This works https://dietpi.com/forum/t/no-usb3-after-apt-upgrade-rock64/6439/29
 

apt install linux-dtb-current-rockchip64=21.08.2 linux-image-current-rockchip64=21.08.2
apt-mark hold linux-dtb-current-rockchip64 linux-image-current-rockchip64

 

I also let @TonyMac32Tony Mac-n-cheese knows on discord. I'm not sure who would find kernel deltas and fix this.

Edited by sgjava
Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...