Jump to content
  • 0

Help : Bricked nanopi m4 after armbian install on emmc





I own a nanopi m4 v1, I know there is no more armbian support neither maintainer for this board but I still enjoy "the other supported variants" which work very good for my needs.

Until now, I only used armbian on sdcards for my system, but today I tried to install it of my emmc module.


Maybe I did somethig stupid, I tried to install the bullseye current cli version from https://www.armbian.com/nanopi-m4/ on my emmc module via armbian-install.

So all process of installation was ok (boot on sdcard then armbian-install => erase / format / install on emmc ...), I choose to boot from emmc too (maybe it was a mistake).

=> After the installation I put off the sdcard (to let only the emmc on the board), then plugin power to boot, but nothing happen (only red light on boot).

From then my board cannot boot anymore, I have only the red light on, no more green light.


I try to flash back sdcard again with a lot of differents images (armbian, legacy versions, friendly elec versions), without any success.

I try with differents sdcards (who worked before), with or without the emmc module plug, nothing worked.

I try too to boot on usb but same result.


So I think the option I choose in armbian-install to boot on emmc maybe change the boot mode of my board ?

Maybe is some eeprom on the board with some kind of boot order which was flash by armbian-install and explains the problem ?


Have anyone have that kind of problem ?

Some ideas to unbrick  my board ?


Thank you


P.S. : My emmc module is ok too, I had friendlycore installed on it and I boot it more earlier today.

I don't have emmc usb reader, so I cannot flash the emmc for now (I used the board for that).



Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
1 hour ago, aworan said:

Have anyone have that kind of problem ?

Recent boot loader has some issues. Our test device is running SD card, where problems weren't detected. Try to build an image with changes similar to those. By using previous boot loader ...


... adding this:



to board config file following by full recompilation.

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines