Jump to content

Ethernet disappeared


Recommended Posts

I have a Rock64, purchased in 2019, that has been running happily for 4 years. I was recently experimenting with hooking it up to a relay board and now I am unable to connect to the internet. I am unsure whether something is fried on the board itself or if this is a software problem I can fix, and unsure how to figure that out.



I have learned more about relay boards now, so I'll do a few things differently and more carefully next attempt, but I had the 5v pin powering the relay board and the 3v pin, GPIO3_A4, and GPIO3_A5 connected to the control side to control two of the board's relays. When connected the Rock's power leds were still on, but either the OS or the internet was down, not sure which. When I then disconnected the relay board, everything worked as normal for a few iterations, but then it remained down even with the relay board disconnected. At this point I logged in over a serial console and found the OS working just fine, but no sign of the ethernet port. This is the current state and I'd like to figure out if it's a fixable one! I have ordered a wifi dongle, but I'd also like to get back ethernet if possible.


I believe the only thing I've done intentionally that may have changed the state of the filesystem was that I ran `dpkg-reconfigure network-manager`. Not sure if that changed anything.

  • The orange light on the ethernet port is lit constantly when the board is on. The green light is always off (now).
  • `lspci` produces no output.
  • `ip a` lists only the `lo` interface:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever


  • `/etc/network/interfaces`:
#source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto eth0
iface eth0 inet dhcp
#       address
#       netmask
#       gateway
#       dns-nameservers
  • USB, emmc, and sd still work
  • Boot output

The only thing I note here is the line `Net:   No ethernet found.` and, at the bottom, several `EXT4-fs error`s. The first makes sense, that's what I'm seeing after bootup. Not sure what to do about the second, if anything.


DDR version 1.13 20180428
ID:0x805 N
Bus Width=32 Col=11 Bank=8 Row=15/15 CS=2 Die Bus-Width=32 Size=4096MB
Boot1 Release Time: Feb  2 2018 15:41:39, version: 2.46
ChipType = 0x11, 143
SdmmcInit=2 0
FwPartOffset=2000 , 2000
SdmmcInit=0 0
FwPartOffset=0 , 0
StorageInit ok = 281382
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = 0, SecureMode = 0
No find bl30.bin
No find bl32.bin
Load uboot, ReadLba = 2000
Load OK, addr=0x200000, size=0xa4e00
RunBL31 0x10000
NOTICE:  BL31: v1.3(debug):f947c7e
NOTICE:  BL31: Built : 20:41:40, Nov 26 2018
NOTICE:  BL31:Rockchip release version: v1.3
INFO:    ARM GICv2 driver initialized
INFO:    Using rkfiq sec cpu_context!
INFO:    boot cpu mask: 1
INFO:    plat_rockchip_pmu_init: pd status 0xe
INFO:    BL31: Initializing runtime services
INFO:    BL31: Preparing for EL3 exit to normal world
INFO:    Entry point address = 0x200000
INFO:    SPSR = 0x3c9

U-Boot 2017.09-armbian (Feb 08 2019 - 11:49:32 +0100)

Model: Pine64 Rock64
DRAM:  4 GiB
MMC:   rksdmmc@ff520000: 0, rksdmmc@ff500000: 1
SF: unrecognized JEDEC id bytes: ff, ff, ff
*** Warning - spi_flash_probe_bus_cs() failed, using default environment

In:    serial@ff130000
Out:   serial@ff130000
Err:   serial@ff130000
Model: Pine64 Rock64
Net:   No ethernet found.
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2958 bytes read in 17 ms (169.9 KiB/s)
## Executing script at 00500000
Boot script loaded from mmc 0
251 bytes read in 14 ms (16.6 KiB/s)
7808508 bytes read in 211 ms (35.3 MiB/s)
18978824 bytes read in 485 ms (37.3 MiB/s)
73680 bytes read in 54 ms (1.3 MiB/s)
** File not found /boot/dtb/rockchip/overlay/-fixup.scr **
## Loading init Ramdisk from Legacy Image at 04000000 ...
   Image Name:   uInitrd
   Image Type:   AArch64 Linux RAMDisk Image (gzip compressed)
   Data Size:    7808444 Bytes = 7.4 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Ramdisk to fc78e000, end fcf005bc ... OK
   reserving fdt memory region: addr=1f00000 size=78000
   Loading Device Tree to 00000000fc713000, end 00000000fc78dfff ... OK

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 4.4.178-rockchip64 (root@armbian.com) (gcc version 7.4.1 20181213 [linaro-7.4-2019.02 revision 56ec6f6b99cc167ff0c2f8e1a2eed33b1edc85d4] (Linaro GCC 7.4-2019.02) ) #4 SMP Wed May 8 19:34:01 CEST 2019
[    0.000000] Boot CPU: AArch64 Processor [410fd034]
[    0.000000] earlycon: Early serial console at MMIO32 0xff130000 (options '')
[    0.000000] bootconsole [uart0] enabled
ERROR:   rockchip_plat_sip_handler: unhandled SMC (0x82000003)
ERROR:   rockchip_plat_sip_handler: unhandled SMC (0x82000003)
[    9.468579] EXT4-fs error (device zram0): ext4_readdir:189: inode #11: comm rsync: path /var/log/lost+found: directory fails checksum at offset 4096
[    9.476883] EXT4-fs error (device zram0): ext4_readdir:189: inode #11: comm rsync: path /var/log/lost+found: directory fails checksum at offset 8192
[    9.485098] EXT4-fs error (device zram0): ext4_readdir:189: inode #11: comm rsync: path /var/log/lost+found: directory fails checksum at offset 12288
[    9.493685] EXT4-fs error (device zram0): ext4_empty_dir:2731: inode #11: block 1: comm rsync: Directory block failed checksum

Ubuntu 18.04.6 LTS katie ttyS2

katie login: trygve
Last login: Tue Jan 17 19:17:17 CST 2023 on ttyS2
 ____   ___   ____ _  ____   _  _
|  _ \ / _ \ / ___| |/ / /_ | || |
| |_) | | | | |   | ' / '_ \| || |_
|  _ <| |_| | |___| . \ (_) |__   _|
|_| \_\\___/ \____|_|\_\___/   |_|

Welcome to ARMBIAN 5.75 stable Ubuntu 18.04.6 LTS 4.4.178-rockchip64
System load:   0.88 0.21 0.07   Up time:       0 min
Memory usage:  2 % of 3988MB    IP:
CPU temp:      30°C
Usage of /:    42% of 15G


Link to comment
Share on other sites

Ethernet missing happened to me too at a Rockpi4A,


Armbian 23.02.02, after enabling rk3328-uart1 overlay in armbian-config.

You need to disable overlay for UART1, then ethernet is back again.

UART1 and Ethernet seems to share a common pin.

Edited by xsider
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines