Jump to content

Cannot boot from microSD

Go to solution Solved by Werner,

Recommended Posts

Hey there,


for quite a while I was using my Station P1 aka T-Firefly ROC-RK3399-PC-PLUS (with a nice case welded around) as crude NAS and wanted to do something new. However for unknown reason I cannot boot from microSD.

I am used to that the Armbian boot loader should switch to microSD when detected so other OS can be used. Does not work though.


It always starts booting from SPI which is fine in theory and then jumps to eMMC which boots fine. With SD inside it does the same. If I remove the eMMC module u-boot stucks to PXE which obviously fails and then drops to U-Boot shell.


I played with that shell for a while including recovery steps (https://docs.armbian.com/User-Guide_Recovery/) (but with correct baud rate) but wasn't successful. On bootz it complains about kernel magic or ARM64 kernel magic, depending on usage of bootz or booti.


Tried erasing SPI but was not successful doing that. rkdeveloptool in maskrom mode stated it erased something but did not change anything. From within Bullseye the SPI flash seems not to be visible. I assume it should be /dev/mtd0 or something?


Kind a running out of ideas...


Images on microSD I tried were 23.02 edge, 22.12 current and 22.02 current.

Link to comment
Share on other sites

This might be interesting. It seems like it tries SD but cannot find valid partitions...


U-Boot 2022.04-armbian (Feb 13 2023 - 01:06:32 +0000)

SoC: Rockchip rk3399
Reset cause: POR
Model: Firefly ROC-RK3399-PC-PLUS Board
DRAM:  3.9 GiB
PMIC:  RK808 
Core:  295 devices, 29 uclasses, devicetree: separate
MMC:   mmc@fe310000: 2, mmc@fe320000: 1, mmc@fe330000: 0
Loading Environment from SPIFlash... SF: Detected w25q128 with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Model: Firefly ROC-RK3399-PC-PLUS Board
Net:   eth0: ethernet@fe300000
Hit any key to stop autoboot:  0 
starting USB...
Bus usb@fe380000: USB EHCI 1.00
Bus usb@fe3c0000: USB EHCI 1.00
Bus usb@fe900000: Register 2000140 NbrPorts 2
Starting the controller
scanning bus usb@fe380000 for devices... 1 USB Device(s) found
scanning bus usb@fe3c0000 for devices... 2 USB Device(s) found
scanning bus usb@fe900000 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found

Device 0: unknown device
switch to partitions #0, OK
mmc1 is current device
** No partition table - mmc 1 **
Couldn't find partition mmc 1:1
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
1:      Armbian
Retrieving file: /boot/uInitrd


Link to comment
Share on other sites

  • Solution

As always the solution pops up once I start complaining :rolleyes:


Seems like my 64G microSD is cursed. It works well on common usage but it refuses to work properly on SBCs. Not wrote the same image to a 32G SD of same quality and brand and it works...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines