How to disable debug info via UART0


Recommended Posts

                Hello all.

I am using bananapi M2+.

I need UART0 for my development.

But while booting, it transmits debug (u-boot) information.

For example:

U-Boot SPL 2016.09-armbian (Oct 24 2016 - 16:40:21)
DRAM: 1024 MiB
Trying to boot from MMC1


U-Boot 2016.09-armbian (Oct 24 2016 - 16:40:21 +0300) Allwinner Technology

CPU:   Allwinner H3 (SUN8I 1680)
Model: Xunlong Orange Pi PC
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0, SUNXI SD/MMC: 1
*** Warning - bad CRC, using default environment

How can I disable it?

Link to post
Share on other sites
Donate and support the project!

In boot.cmd

Try to modify

 

setenv bootargs "console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p ............."

to 

setenv bootargs "console=tty1 root=/dev/mmcblk0p .............."

 

and don't forget to recompile

# Recompile with:
# mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr
Link to post
Share on other sites
U-Boot SPL 2016.09-armbian (Oct 24 2016 - 16:40:21)
DRAM: 1024 MiB
Trying to boot from MMC1


U-Boot 2016.09-armbian (Oct 24 2016 - 16:40:21 +0300) Allwinner Technology

CPU:   Allwinner H3 (SUN8I 1680)
Model: Xunlong Orange Pi PC
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0, SUNXI SD/MMC: 1
*** Warning - bad CRC, using default environment

How can I disable it?

This part can only be disabled by patching and recompiling u-boot.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.