Jump to content

A95X F3 AIR no video

Recommended Posts



I have an A95X F3 Air tv box that has an s905x3 chipset. I followed the instructions here. I believe i used the correct dtb file and tested out multiple others. I've tried reformatting my drive with SD card formatter. I've tried flashing my stock firmware. However I cannot seem to get armbian to boot. I'm getting no video output. I'm not sure what I'm doing wrong here. I've searched high and low on the internet and I could not find a solution. I have seen aml_autoscript.zip being mentioned here and there however the image I've downloaded doesn't seem to have it. Any help would be appreciated.

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Posted (edited)


I have just received the same type of device and started trying to install the Armbian firmware.

I have followed the steps in SteeMans post here: 





The steps I have taken are listed below.

I am using the "toothpick" method to power up with the boot switch depressed, then releasing after a few seconds. (How long should it be??)

But no luck.


Obviously someone has done this before since there is a dtb file specifically for this device, so I think I am missing some step along the way.

I have installed Armbian on a S2905 device previously, but not the S2905X3 which is used in this device.


Other than finding some problem with my installation process, the only alternative would seem to be just trying out all the dtb files in turn.

But that sounds dubious in the face of there being a specific dtb file for the device.


Any comments, advice or suggestions would be very welcome.

Thanks in advance.





1. Download firmware:
    Stable Builds: https://redirect.armbian.com/aml-s9xx-box/archive
2. Burn the firmware to SD card with Etcher
3. Edit the    armbi-boot /extlinux/extlinux.conf    file to point to the appropriate dtb file:
  LABEL Armbian
  LINUX /uImage
  INITRD /uInitrd

  FDT /dtb/amlogic/meson-sm1-a95xf3-air.dtb
  append root=UUID=afbf3a1b-d905-4b27-b78a-3682d3db0dca rootflags=data=writeback console=ttyAML0,115200n8 console=tty0 rw no_console_suspend consoleblank=0     fsck.fix=yes fsck.repair=yes net.ifnames=0 splash plymouth.ignore-serial-consoles

4. Copy armbi-boot /u-boot-s905x2-s922  to  /u-boot.ext

5. Install the SD card and attempt to boot



Edited by tgillett
Link to comment
Share on other sites

Posted (edited)



I used an SD card that was set up and working in a S905 based device, using an earlier version of Armbian.

I added the new dtd file (/dtb/amlogic/meson-sm1-a95xf3-air.dtb) and adjusted extlinux.conf accordingly.

I copied   u-boot-s905x2-s922   to   u-boot-ext.


Then I did the toothpick boot thing and held it for around 30 secs (not sure if this duration had any specific effect).

After releasing the boot switch, the boot process started and it ended up running just like the previous S905 device.


I then went back and tried again with the stable build that @SteeMan referenced, but that failed.

So there seems to be some outstanding issue that needs a bit more time and testing to sort out.


But at least now I know the dtb and u-boot files are ok so it is easier to try out other things.


I have to say that the S905X3 processor handles the workload (Kolibri application) with much less effort than the previous S905 device.


Hope this helps.



Edited by tgillett
Link to comment
Share on other sites

Just for the record...


The image file I used to get my S905X3 box running was from this tutorial:


which references this site for the image file:


The file is:


I used the dtb file  "meson-sm1-a95xf3-air.dtb"  from the Stable image referenced in SteeMans post.


This at least gets the board running and allows for an upgrade to the Debian Bullseye operating system using the apt-get command.


I can't get the current Stable images from the site referred to in SteeMans post here to work:




Also the SHA checksums for these files don't seem to agree with the published value, so it may be there is some problem...



I hope this helps.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines