Jump to content

Firefox video playback error due to ffmpeg+libav forced hardware-acceleration


Recommended Posts

This is a HTML5 audio/video tester for web browsers: https://tools.woolyss.com/html5-audio-video-tester/

As you can see .webm is not enabled because frankly I have no idea which package I need to enable that.


I have opus and av1 installed:

ii  libdav1d5:arm64  0.9.2-1          arm64  fast and small AV1 video stream decoder (shared library)
ii  libopus0:arm64   1.3.1-0.1build2  arm64  Opus codec runtime library


I tried gstreamer1.0-ugly and gstreamer1.0-bad but to no avail.


Any idea's which package I am missing?





Edited by Dantes
Link to comment
Share on other sites

8 hours ago, Dantes said:

Any idea's which package I am missing?

Not a missing package, it is the lack of basic support for V4L2-M2M hardware-accelerated video decode  in the application in the first place. The next showstopper would be the lack of V4L2-M2M support in the ffmpeg framework. There are some hack patches in the wild, but no out-of-the-box solution. The next showstopper would be the lack of kernel support for the SOC video decoder IP.
The lack of support in the application is a general problem for all devices that provide their decoders via V4L2-M2M. The lack of support in the ffmpeg framework is a problem for all applications that base on it. Gstreamer-based applications, on the other hand, offer out-of-the-box solutions, as the necessary support is already integrated into the mainline gstreamer framework.

Link to comment
Share on other sites

Not talking about hardware accelerated support


Software rendering works just fine in mpv. I thought firefox maybe needed an extra package, but it seems the online videos I tested are broadcasts. That's the only thing that makes sense :lol:. Local rendering work just fine, just not accelerated.


Thanks for your time though.


Link to comment
Share on other sites

I ran into this problem again today which I thought to be solved, but it seems to be related to the hardware acceleration. Afaict HWA does not play nice with Firefox/YouTube even if it is disabled.


So I decided to boot into an sdcard WITHOUT hardware acceleration and YouTube videos play just fine in Firefox


Then booted into an sdcard WITH hardware acceleration and disabled HWA in Firefox but YouTube videos are not working anymore :huh:


Settings I changed:

* settings > general > performance

         unchecked "Use recommended performance settings"
            unchecked "Use hardware acceleration when available"

* about:config

      media.hardware-video-decoding.enabled            false

      media.hardware-video-decoding.force-enabled  false


at this point I do not know if its me or driver related.

Link to comment
Share on other sites

I think that Firefox is still using the 3D-accelerated ffmpeg+libavcodec , so the only solution I see now is to remove the 3D acceleration and reinstall ffmpeg+libavcodec. (and it works but the tradeoff is no 3DA/HWA)


So there is no easy switching :P

Edited by Dantes
Link to comment
Share on other sites

  • Werner changed the title to Firefox video playback error due to ffmpeg+libav forced hardware-acceleration

Well I did another installation today, too many sdcards I guess.

This seems to work just fine :D


sudo add-apt-repository ppa:liujianfeng1994/panfork-mesa --yes
sudo apt update --yes
sudo apt upgrade --yes


and it only installs these packages:


* mali-g610-firmware:arm64 (1.0.1 automatic)
* libglx-mesa0:arm64 (22.2.5-0ubuntu0.1~22.04.3, 23.0~panfork~csf~git221210.120202c6757~j+3)
* libgbm1:arm64 (22.2.5-0ubuntu0.1~22.04.3, 23.0~panfork~csf~git221210.120202c6757~j+3)
* libgl1-mesa-dri:arm64 (22.2.5-0ubuntu0.1~22.04.3, 23.0~panfork~csf~git221210.120202c6757~j+3)
* libglapi-mesa:arm64 (22.2.5-0ubuntu0.1~22.04.3, 23.0~panfork~csf~git221210.120202c6757~j+3)
* libegl-mesa0:arm64 (22.2.5-0ubuntu0.1~22.04.3, 23.0~panfork~csf~git221210.120202c6757~j+3)


I have no issues with Firefox or Kodi at this point. Feel free to test and comment, because I sometimes feel I'm talking to myself here too much ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines