1 1
grg

Disable login on ttyGS0

Recommended Posts

I'd like to be able to plug my laptop into the USB OTG port and use that serial connection to communicate with an application on the orange pi. The default configuration is to give me a login. What's the correct way to change the getty settings for ttyGS0?

 

Thanks!

Share this post


Link to post
Share on other sites

It seems to be somewhat nuanced (well, at least from the perspective of someone like me that hasn't done much systemctl stuff).

 

I tried that command previously and it didn't work. It seems you have to plug your USB cable in between the Orange Pi and the other computer you're using *before* you disable that tty. Doing so will make sure you have the other device available (on my Mac it's /dev/tty.usbmodem1411). Once you've done that, you can then disable serial-getty@ttyGS0.service.

 

Then you're able to use screen (or whatever) to communicate over that connection.

 

If you reboot with it *disabled*, upon reboot, you can't establish the connection (/dev/tty.usbmodem1411 doesn't populate on the other host). This is where I was stuck before.

 

The interesting thing is that the status from "sudo systemctl status serial-getty@ttyGS0.service" shows the same either way. Also, the kernel modules is loaded in each cases.

 

Anyway, I'll dig around and see if I can figure out what's causing that. Thanks for the input. It pushed me in the right direction and helped me find that little inconsistency.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1