Jump to content

Cannot boot since update to Linux 6.1.11-meson64


Recommended Posts



I recently updated my N2 server from Bullseye to Bookworm. Reboot went fine. I then noticed I still had the old kernel from the linux-image-odroidn2 package (4.9.190-odroidn2), so I ran armbian-config, and told it to switch to linux-image-current-meson64. It installed packages for a bit, then rebooted on its own without asking. Since then, every boot is stuck with a U-boot logo at the top right of the screen.


What I tried:


  • Fixed a couple of issues in /boot (zImage was a symlinked to the old `vmlinuz-4.9.190-odroidn2` that no longer existed, I made it point to `vmlinuz-6.1.11-meson64` instead; `boot.ini` referred to `boot/dtb/amlogic/meson64_odroidn2.dtb` instead of `boot/dtb/amlogic/meson-g12b-odroid-n2.dtb`).
  • Chrooted from a working sdcard to run `apt reinstall linux-image-current-meson64 linux-u-boot-odroidn2-current` (with /dev /sys /proc bind-mounted)
  • Restored from a backup (before the kernel update)
  • Copied all of /boot from a working N2 sdcard to this one.


However, booting from another sdcard on the same board still works.


Any idea what I can do next to fix this sdcard?


Thank you for your help

Edited by val
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines