Jump to content

Initramfs can't find /dev/mmcblk1p1

Go to solution Solved by Gunjan Gupta,

Recommended Posts

Hi all,

I have been using armbian jammy on my potato without issues.

But since the weekend it only boots to initramfs and says can't find mmcblk1p1

I put the sdcard a live gparted and partitions are and verified.

In initramfs I can find in /dev the mmcblk0p1 but not the mmcblk1p1

Now how can I change the boot or the name of the device?


Board: Le Potato
Edited by Roberto Rodrigues
Wring tag
Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Another info, in initramfs I created a symlink to the missed file

ln /dev/mmcblk0p1 /dev/mmcblk1p1

After having the link created I typed exec init and it started to boot, but off course it fails, because the initramfs gets cleaned. So where the hell is where I change the name is the mmc file to boot?

Best regards


Link to comment
Share on other sites

  • Solution

This is interesting one. Kind of like how sd card names are different between different version of RPi.


You haven't mentioned the image you are using. But from the post I am deducing it was working fine for you until you installed an update?


I am not 100% sure as this is not a device I work with. But generally the root device is set in a file called armbianEnv.txt. Here is something for you to try 


mount your root partition

mount /dev/mmcblk0p1 /mnt

check if /mnt/boot/armbianEnv.txt exists

ls /mnt/boot/armbianEnv.txt

if it doesn't exists, create it. Replace <Your UUID> with UUID shown in output of blkid command

echo "rootdev=UUID="<Your UUID>" > /mnt/boot/armbianEnv.txt

unmount your root partition

umount /mnt

and reboot

Link to comment
Share on other sites

Many Thanks Gunjan Gupta

It really worked the adding of the line echo


Indeed i had done some updates, but i don't remember if i did any to kernel or something like that.

The line echo had to be changed to like


echo rootdev=UUID="<Your UUID>" >> /mnt/boot/armbianEnv.txt

Because the file existed, but had no line to boot the sdcard.


Thanks once again.

Hope this helps others.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines