Jump to content

Packetloss on OrangePi5

Recommended Posts

Standard install - Armbian Bookworm, full 'firmware install'. I am getting some packet loss over the LAN. A raspberry pi, Synology NAS and Deban x86 install on the same LAN do not seem to exhibit the same loss. Anyone have experience or ideas? Oddly enough this never seems to occur on fresh installs. This is a docker host for pihole and home assistance, no other packages are really installed at all.


I've not really tried much, but since this is a standard install, apt-get update & upgrade are about the only modifications outside of docker install that has occurred.


1. This plugs directly in to a Ubiquiti switch

2. I have tried a few different ethernet cables.

3. dmesg does not really show disconnects on the regular




Edited by obiwantoby
Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

It could be about anything, but what did help for LinuxCNC was setting the smp affinity of the Ethernet adapter to another CPU

cat /proc/interrupts | grep eth


Then you'll see 2 IRQs then set these to other CPU(s). In HEX format. Convert from binary to HEX, the binary is reversed. So 00001111 is the first 4 and to HEX is F.

To set them to the 5th CPU (CPU4) for example: 0001 0000 -> 10


(change the IRQ numbers)

echo 10 | sudo tee /proc/irq/82/smp_affinity && echo 10 | sudo tee /proc/irq/81/smp_affinity


If that does help you could set it at boot in rc.local or crontab with 10 seconds delay.


Link to comment
Share on other sites

I played around with affinity, no change. It got so bad that via SSH I'd be kicked off or my commands would partially input. I did a restore from backup, and since I do use docker, back up and running perfectly again. I wish I knew what was tainting the system though. 

Could it be this or similar? https://community.home-assistant.io/t/home-assistant-in-docker-causes-network-packet-loss-on-host/520067 Unknown, as I am not running anything privileged. 

I am not sure *if* this is a hint as well. There has to be an explanation but as to what still at a loss. Especially since I can restore like I did, and everything is working perfectly. Perhaps I should just avoid apt-get upgrades ;)



Link to comment
Share on other sites

Stop and disable Docker and you'll know.

Did you check the temperature while this happens? "armbianmonitor -m"

Tried another network cable, another place (interference), power supply, cpu governor "echo performance | sudo tee /sys/bus/cpu/devices/cpu[0-7]/cpufreq/scaling_governor".

Did you install another network manager?

Does dmesg show you something?

Other devices connected to the OPi 5?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines