Jump to content

Dualsense recognized and paired but dont works


Recommended Posts

I purchased this board to use as a gaming station and, among the options, I'm using moonlight with sunshine to stream my steam to the room, which is working wonderfully well, but I'm having a problem.
When pairing the control with Armbian, it is recognized as a joystick but I cannot use it in any way.
I have two Sony Dualsense joysticks, I tested them both with cable and Bluetooth and the problem is the same.
Can anyone guide me where I can start to debug the problem?

NOTE: I borrowed an IPEGA joystick and it worked normally.


[ 1107.997887] playstation 0005:054C:0CE6.0007: unknown main item tag 0x0
[ 1107.998309] playstation 0005:054C:0CE6.0007: hidraw3: BLUETOOTH HID v1.00 Gamepad [DualSense Wireless Controller] on 00:1a:7d:da:71:13
[ 1108.025139] input: DualSense Wireless Controller as /devices/platform/usbdrd3_0/fc000000.usb/xhci-hcd.11.auto/usb7/7-1/7-1:1.0/bluetooth/hci0/hci0:71/0005:054C:0CE6.0007/input/input22
[ 1108.025917] input: DualSense Wireless Controller Motion Sensors as /devices/platform/usbdrd3_0/fc000000.usb/xhci-hcd.11.auto/usb7/7-1/7-1:1.0/bluetooth/hci0/hci0:71/0005:054C:0CE6.0007/input/input23
[ 1108.026601] input: DualSense Wireless Controller Touchpad as /devices/platform/usbdrd3_0/fc000000.usb/xhci-hcd.11.auto/usb7/7-1/7-1:1.0/bluetooth/hci0/hci0:71/0005:054C:0CE6.0007/input/input24
[ 1108.027180] playstation 0005:054C:0CE6.0007: Cannot register multicolor LED device
[ 1108.027219] playstation 0005:054C:0CE6.0007: Failed to create dualsense.
[ 1108.217580] playstation: probe of 0005:054C:0CE6.0007 failed with error -22


Edited by Sr_-Caio
Link to comment
Share on other sites

Exactly the same problem here. Radxa Rock Pi 5B board, kernel 5.10.160-rockchip, Ubuntu Jammy, but not Armbian though. KDE Plasma on Wayland. Dualsense connected via USB cable.


tux@rock5b ~> sudo dmesg -c
[24478.813550] usb 1-1.2: new high-speed USB device number 6 using ehci-platform
[24479.015817] usb 1-1.2: New USB device found, idVendor=054c, idProduct=0ce6, bcdDevice= 1.00
[24479.015848] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[24479.015868] usb 1-1.2: Product: Wireless Controller
[24479.015885] usb 1-1.2: Manufacturer: Sony Interactive Entertainment
[24479.039947] playstation 0003:054C:0CE6.0006: hidraw3: USB HID v1.11 Gamepad [Sony Interactive Entertainment Wireless Controller] on usb-fc800000.usb-1.2/input3
[24479.095097] input: Sony Interactive Entertainment Wireless Controller as /devices/platform/fc800000.usb/usb1/1-1/1-1.2/1-1.2:1.3/0003:054C:0CE6.0006/input/input18
[24479.097053] input: Sony Interactive Entertainment Wireless Controller Motion Sensors as /devices/platform/fc800000.usb/usb1/1-1/1-1.2/1-1.2:1.3/0003:054C:0CE6.0006/input/input19
[24479.098565] input: Sony Interactive Entertainment Wireless Controller Touchpad as /devices/platform/fc800000.usb/usb1/1-1/1-1.2/1-1.2:1.3/0003:054C:0CE6.0006/input/input20
[24479.101621] playstation 0003:054C:0CE6.0006: Cannot register multicolor LED device
[24479.101668] playstation 0003:054C:0CE6.0006: Failed to create dualsense.
[24479.270606] playstation: probe of 0003:054C:0CE6.0006 failed with error -22


Modules seem to be loaded.


tux@rock5b ~> lsmod 
Module                  Size  Used by
hid_playstation        20480  0
tls                    90112  0
bnep                   24576  2
xt_conntrack           16384  1
nft_chain_nat          16384  3
xt_MASQUERADE          16384  1
nf_nat                 57344  2 nft_chain_nat,xt_MASQUERADE
nf_conntrack_netlink    40960  0
nf_conntrack          135168  4 xt_conntrack,nf_nat,nf_conntrack_netlink,xt_MASQUERADE
nf_defrag_ipv6         20480  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
nft_counter            16384  15
xt_addrtype            16384  2
nft_compat             20480  4
nf_tables             172032  43 nft_compat,nft_counter,nft_chain_nat
nfnetlink              16384  4 nft_compat,nf_conntrack_netlink,nf_tables
br_netfilter           24576  0
bridge                200704  1 br_netfilter
stp                    16384  1 bridge
llc                    16384  2 bridge,stp
squashfs               45056  0
overlay               110592  0
binfmt_misc            20480  1
joydev                 20480  0
pwm_fan                16384  0
panfrost               57344  0
gpu_sched              28672  1 panfrost
dm_multipath           28672  0
dm_mod                106496  3 dm_multipath
sch_fq_codel           20480  3
fuse                  110592  5
ip_tables              28672  0
ipv6                  438272  138 bridge,br_netfilter
raid10                 45056  0
raid456               131072  0
async_raid6_recov      16384  1 raid456
async_memcpy           16384  1 raid456
async_pq               16384  1 raid456
async_xor              16384  2 async_pq,raid456
async_tx               16384  5 async_pq,async_memcpy,async_xor,raid456,async_raid6_recov
raid1                  40960  0
raid0                  20480  0
multipath              20480  0
linear                 16384  0
md_mod                126976  6 raid1,raid10,raid0,linear,raid456,multipath
pgdrv                  16384  0


Any idea what could be wrong?

Link to comment
Share on other sites

sunarowicz, any update?
I have done a test with the new kernel version and the dualsense works... but on the new kernel i have lost Video Acceleration on moonlight, so, no stream... its a shame, i really liked the armbian with moonlight, but i will search another solution for now

Link to comment
Share on other sites

Well, I didn't try since then. So I tried now because you are asking and voila, it works! Tried that in GFN. I didn't do anything except upgrading to latest Ubuntu with the new kernel.

tux@rock5b ~> uname -a
Linux rock5b 6.1.0-1016-rockchip #16-Ubuntu SMP Thu Jun  6 00:11:54 UTC 2024 aarch64 aarch64 aarch64 GNU/Linux


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines