0
wildcat_paris

compile.sh stops on "Installing Armbian on the top of Ubuntu trusty base system"

Recommended Posts

Hello Igor,

 

I am starting exploring your nice "lib" tools for mainline/lamobo/trusty and end with this error message.

 

the host is trusty / amd64 / quad cores / 8 GB RAM

 

unsure if /bin/mktemp refers to loopback device or host /tmp


                                  lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
                                  x Installing Armbian on the top of Ubuntu trusty base system ...     x
                                  x                                                                    x
                                  x build-essential                                                    x
                                  x                                                                    x
                                  x  lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk  x
                                  x  x                               0%                             x  x
                                  x  mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj  x
                                  mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj

[ error ] Installation failed
Setting up cmake-data (2.8.12.2-0ubuntu3) ...
Setting up cmake (2.8.12.2-0ubuntu3) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Processing triggers for ca-certificates (20141019ubuntu0.14.04.1) ...
/bin/mktemp: failed to create file via template '/tmp/user/0/ca-certificates.crt.tmp.XXXXXX': No such file or directory
dpkg: error processing package ca-certificates (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 ca-certificates
E: Sub-process /usr/bin/dpkg returned an error code (1)

FYI

gr@gr /run $ df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/sda1          115G     63G   47G  58% /
none               4,0K       0  4,0K   0% /sys/fs/cgroup
udev               3,9G    4,0K  3,9G   1% /dev
none               1,0G    8,0K  1,0G   1% /tmp
tmpfs              799M    1,1M  798M   1% /run
none               5,0M       0  5,0M   0% /run/lock
none               3,9G       0  3,9G   0% /run/shm
none               100M       0  100M   0% /run/user
ramlog-tmpfs       2,0G    706M  1,3G  36% /var/log
/dev/sda2          991M    105M  820M  12% /boot
/dev/sdb6          210G    141G   59G  71% /home2
/dev/sdc1          1,8T    533G  1,2T  31% /home4
/dev/mapper/sdd1   1,8T     93M  1,7T   1% /home5
/dev/loop0p1       3,8G    526M  3,1G  15% /home/gr/armbian/output/cache/sdcard
chdev              3,9G    4,0K  3,9G   1% /home/gr/armbian/output/cache/sdcard/dev

regards, Guillaume

 

 

Share this post


Link to post
Share on other sites

Never saw such error. It must be related to some sort of corruption withing base system. If you run the script and rerun again some process could hang so sometimes reboot is needed.

 

It's recommended that you run this script within virtual machine and update script libraries /lib too. All of your changes should be inside compile.sh call script - for general / basic work. If you haven't touched them, they are auto updated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0