Jump to content

Unable to upgrade armbian-bsp-cli-orangepi5-plus-legacy on userbuilt armbian 23.11


Recommended Posts

I built armbian using the branch 23.11 with legacy-kernel 5.10.160 for use as a Nextcloud server.

Version: Armbian-unofficial 23.11.0-trunk Bullseye \l . 5.10.160-legacy-rk35xx


After running sudo apt upgrade there were a few packages which were being upgraded successfully from 23.11.0-trunk to 23.11.1.
Unfortunately the package armbian-bsp-cli-orangepi5-plus-legacy cannot be upgraded to 23.11.1 due to the base-files still being on 23.11.0-trunk. The system is running fine though.


$ sudo apt update && sudo apt list --upgradable
Hit:2 http://deb.debian.org/debian bullseye InRelease
Hit:3 http://deb.debian.org/debian bullseye-updates InRelease
Hit:4 http://deb.debian.org/debian bullseye-backports InRelease
Hit:5 http://security.debian.org bullseye-security InRelease
Hit:6 https://packages.sury.org/php bullseye InRelease
Hit:1 http://mirrors.dotsrc.org/armbian-apt bullseye InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
Listing... Done
armbian-bsp-cli-orangepi5-plus-legacy/bullseye 23.11.1 arm64 [upgradable from: 23.11.0-trunk]

$ sudo apt install --only-upgrade armbian-bsp-cli-orangepi5-plus-legacy
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 armbian-bsp-cli-orangepi5-plus-legacy : Depends: base-files (>= 23.11.1) but 23.11.0-trunk-11.1+deb11u8-bullseye is to be installed
E: Unable to correct problems, you have held broken packages.

$ apt-cache policy base-files
  Installed: 23.11.0-trunk-11.1+deb11u8-bullseye
  Candidate: 23.11.0-trunk-11.1+deb11u8-bullseye
  Version table:
 *** 23.11.0-trunk-11.1+deb11u8-bullseye 100
        100 /var/lib/dpkg/status
     23.8.1-bullseye 500
        500 http://apt.armbian.com bullseye/main arm64 Packages
     11.1+deb11u9 500
        500 http://deb.debian.org/debian bullseye/main arm64 Packages


How do I fix this issue?
Is there a safe way to upgrade the base-files to 23.11.1? I cannot rebuild the system!


Any help is appreciated:)

Link to comment
Share on other sites

Att I was able to upgrade it by using the beta package of base-files which has now been removed from beta repositories, they made some tweak to produce that bullseye base-files and never did it again

Edited by j0ta
Link to comment
Share on other sites

An update

it seems you can use the bookworm base-files deb on a bullseye system


It will change /etc/debian_version to 12.5

revert to 11.x with

I forgot to check bullseye version before apply the bookworm base-file

if someone can, post the correct  bullseye version


Cheers !

Edited by j0ta
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines