Jump to content
  • 0

Slow internet speed by using OPI as wifi-wifi router


Aberkoke
 Share

Question

Hi everyone,

 

I have an orange pi pc+ (also a orange pi one) and i'm trying to use one of them as a wifi-wifi router. I've been able to do it work several times, with different wifi dongles, armbian versions (both debian and ubuntu legacy and mainline) but I always get low wifi speed in the AP interface.

 

The problem is that the AP network through the orange pi always gives  me around 30-10% of the full internet connection. That is, if my connection gives me 1.5mb/s, the client interface at orange pi gives around 1.5mb/s but at the AP interface is only 200-500 kb/s.

 

I'm going to show here the last configuration I've tried. I would like to achieve a "decent" wifi speed in the AP interface.

 

Current configuration information:

Orange PI PC+
Armbian server, ubuntu, legacy 5.25 (updated)

WIFI client: wlan0 interface, internal wifi of opipc+
WIFI ap: ra0 interface. MT7601u using this driver (https://github.com/muratdemirtas/MT7601u)

/etc/network/interfaces

# Wired adapter #1
allow-hotplug eth0
no-auto-down eth0
iface eth0 inet dhcp

# Local loopback
auto lo
iface lo inet loopback

#CLIENT
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

#AP
allow-hotplug ra0
iface ra0 inet static
address 192.168.42.1
netmask 255.255.255.0

/etc/default/isc-dhcp-server

# Defaults for isc-dhcp-server initscript
# sourced by /etc/init.d/isc-dhcp-server
# installed at /etc/default/isc-dhcp-server by the maintainer scripts

#
# This is a POSIX shell fragment
#

# Path to dhcpd's config file (default: /etc/dhcp/dhcpd.conf).
#DHCPD_CONF=/etc/dhcp/dhcpd.conf

# Path to dhcpd's PID file (default: /var/run/dhcpd.pid).
#DHCPD_PID=/var/run/dhcpd.pid

# Additional options to start dhcpd with.
#	Don't use options -cf or -pf here; use DHCPD_CONF/ DHCPD_PID instead
#OPTIONS=""

# On what interfaces should the DHCP server (dhcpd) serve DHCP requests?
#	Separate multiple interfaces with spaces, e.g. "eth0 eth1".
INTERFACES="ra0"

/etc/dhcp/dhcpd.conf

ddns-update-style none;

default-lease-time 600;
max-lease-time 7200;

authoritative;

log-facility local7;

    subnet 192.168.42.0 netmask 255.255.255.0 {
    range 192.168.42.10 192.168.42.50;
    option broadcast-address 192.168.42.255;
    option routers 192.168.42.1;
    default-lease-time 600;
    max-lease-time 7200;
    option domain-name "local";
    option domain-name-servers 8.8.8.8, 8.8.4.4;
    }

iptables

# Generated by iptables-save v1.6.0 on Fri Feb 10 23:53:52 2017
*filter
:INPUT ACCEPT [158:23636]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [121:19924]
-A FORWARD -i wlan0 -o ra0 -m state --state RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -i ra0 -o wlan0 -j ACCEPT
COMMIT
# Completed on Fri Feb 10 23:53:52 2017
# Generated by iptables-save v1.6.0 on Fri Feb 10 23:53:52 2017
*nat
:PREROUTING ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:OUTPUT ACCEPT [3:195]
:POSTROUTING ACCEPT [3:195]
-A POSTROUTING -o wlan0 -j MASQUERADE
COMMIT
# Completed on Fri Feb 10 23:53:52 2017

/etc/sysctl.conf

net.ipv4.ip_forward=1
vm.swappiness=0

/etc/Wireless/RT2870AP/RT2870AP.dat (equivalent to hostapd.conf)

#The word of "Default" must not be removed
Default
CountryRegion=5
CountryRegionABand=7
CountryCode=TW
BssidNum=1
SSID=HD_MESH_1
WirelessMode=9
TxRate=0
Channel=11
BasicRate=15
BeaconPeriod=100
DtimPeriod=1
TxPower=100
DisableOLBC=0
BGProtection=0
TxAntenna=
RxAntenna=
TxPreamble=0
RTSThreshold=2347
FragThreshold=2346
TxBurst=1
PktAggregate=0
TurboRate=0
WmmCapable=0
APSDCapable=0
DLSCapable=0
APAifsn=3;7;1;1
APCwmin=4;4;3;2
APCwmax=6;10;4;3
APTxop=0;0;94;47
APACM=0;0;0;0
BSSAifsn=3;7;2;2
BSSCwmin=4;4;3;2
BSSCwmax=10;10;4;3
BSSTxop=0;0;94;47
BSSACM=0;0;0;0
AckPolicy=0;0;0;0
NoForwarding=0
NoForwardingBTNBSSID=0
HideSSID=0
StationKeepAlive=0
ShortSlot=1
AutoChannelSelect=0
IEEE8021X=0
IEEE80211H=0
CSPeriod=10
WirelessEvent=0
IdsEnable=0
AuthFloodThreshold=32
AssocReqFloodThreshold=32
ReassocReqFloodThreshold=32
ProbeReqFloodThreshold=32
DisassocFloodThreshold=32
DeauthFloodThreshold=32
EapReqFooldThreshold=32
PreAuth=0
AuthMode=WPA2PSK
EncrypType=TKIP;AES
RekeyInterval=0
RekeyMethod=DISABLE
PMKCachePeriod=10
WPAPSK=12345678
DefaultKeyID=1
Key1Type=0
Key1Str=
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
HSCounter=0
AccessPolicy0=0
AccessControlList0=
AccessPolicy1=0
AccessControlList1=
AccessPolicy2=0
AccessControlList2=
AccessPolicy3=0
AccessControlList3=
WdsEnable=0
WdsEncrypType=NONE
WdsList=
WdsKey=
RADIUS_Server=192.168.2.3
RADIUS_Port=1812
RADIUS_Key=ralink
own_ip_addr=192.168.5.234
EAPifname=br0
PreAuthifname=br0
HT_HTC=0
HT_RDG=0
HT_EXTCHA=0
HT_LinkAdapt=0
HT_OpMode=0
HT_MpduDensity=5
HT_BW=1
HT_AutoBA=1
HT_AMSDU=0
HT_BAWinSize=64
HT_GI=1
HT_MCS=33
MeshId=MESH
MeshAutoLink=1
MeshAuthMode=OPEN
MeshEncrypType=NONE
MeshWPAKEY=
MeshDefaultkey=1
MeshWEPKEY=
WscManufacturer=
WscModelName=
WscDeviceName=
WscModelNumber=
WscSerialNumber=
RadioOn=1
PMFMFPC=0
PMFMFPR=0
PMFSHA256=0

As I said before, this configuratin works. I've also tried with other wifi dongle, using the pertinent "hostapd.conf" file and the result is the same. One more thing:

local network wifi speed is around 14-15 Mbits/S. Tested with iperf

So I think the problem is when the opi fordwars internet thorugh from wlan0 to ra0.

 

Any ideas or questions?

 

Deeply grateful guys!

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Open source development is fun. Join Armbian Linux development team today!

  • 0

don't understand your usecase are you trying to do some kind of repeater ?

change the client connection to lan and recheck the speeds

 

if the transfer speed is slow it usually always means that the client connection is too weak.

any 20-30EUR wlan router will always outperform just by using pure antenna power

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...