Jump to content

Orange Pi Zero 3, WIFI AP mode: protocol 0000 is buggy, dev wlan0


Recommended Posts

Hi! So the problem is when I configure wifi hotspot using hostapd, isc-dhcp-server, and ifupdown, I'm able to start the AP, connect to it, and ping. However, the moment any device connects to the AP the serial console gets spammed with this message around once a second:

protocol 0000 is buggy, dev wlan0

This happens on the unofficial Armbian build (from the Armbian OrangePi Zero3 page), DietPi, and the official OrangePi Debian build. 

The wireless band doesn't matter.

Kernel version: 6.1.31-sun50iw9.

I tried to set up the AP with NetworkManager, but couldn't manage to connect to it. Probably DHCP issues that I couldn't resolve.


I haven't run the AP for a prolonged period, only like 1hour. So I'm not sure if this has any effect on the performance and stability.

Could somebody suggest if this is something to worry about or just a harmless warning?

Edited by Dariy
Link to comment
Share on other sites

the 'community' one is here, scroll right to the bottom


and the kernel version is at least 6.6 and above


apparently someone has seen the same , so it isn't 'new'



if one google around the web one may stumble into this



it could mean a device you have is sending out goofy packets that are not regular IP packets. the normal protocols used are usually TCP, UDP and ICMP.


Link to comment
Share on other sites

@ag123Thanks for your response!


I've googled it, and seen those posts (mainly on network routers forums). Unfortunately, did not find a way to debug this, or to fix.


I've tried with different devices: 2 windows laptops, 2 android phones. I don't think they would send any goofy packages. Why would they? I don't know how to debug anyway.


Thanks for pointing out the proper topic, will post a message there later. I'll try the latest armbian build with linux 6.6+ to check if the problem persists.

Link to comment
Share on other sites

Reporting: with the latest Armbian release from the OPi Zero3 "Armbian_community 24.5.0-trunk.248 Bookworm with Linux 6.6.22-current-sunxi64".

The Network Manager is disabled, downloaded ifupdown, hostapd, and isc-dhcp-server (to make the experiment clean). The same configuration.

Problem solved! No messages about buggy protocols, just works just fine.



Link to comment
Share on other sites

On 5/2/2024 at 9:28 AM, robertoj said:

Please, can you share your hostapd.conf



I'm sorry for the delay.

Here you go:



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines