0
Fares

Compile New Kernel on Hummingboard

Recommended Posts

Hello everyone,

 

I am a beginner in Linux.
I have a Hummingboard i2ex and I am running Armbian_5.30_Cubox-i_Ubuntu_xenial_4.11.4_desktop on it.
Trying to use a CSI Tool, I have to compile and install this kernel : https://github.com/xieyaxiongfly/Atheros-CSI-Tool.git

Here are the steps that I did on the Hummingboard:
( you can see the tutorial: http://pdcc.ntu.edu.sg/wands/Atheros/document/Atheros-CSI-Tool-User-Guide.pdf )

1) sudo apt-get install git (to clone the source)
2) sudo apt-get install libncurses5-dev libncursesw5-dev (to run makemenuconfig)
3) git clone https://github.com/xieyaxiongfly/Atheros-CSI-Tool.git
4) Enter the dir ~/Atheros-CSI-Tool/
5) make menuconfig (use the default config provided by the kernel)
6) make
7) make modules
8) sudo make modules_install
9) sudo make install

The compilation works fine and the make install command creates the following files in the /boot directory.
◾vmlinuz-4.1.10-fslc-imx6-sr+
◾System.map-4.1.10-fslc-imx6-sr
◾initrd.img-4.1.10-fslc-imx6-sr
◾config--4.1.10-fslc-imx6-sr

 

Then I copy the zImage Atheros-CSI-Tool/arch/arm/boot/zImage to the boot partition /boot.
But when I reboot the hummingboard, I get no HDMI output and in the serial console I get the initialization and then Starting kernel ...

Do you have any idea if the process is alright and how can I run this kernel on my Hummingboard.

Thanks in advance,
Fares

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0