Jump to content

Fully Preemptible kernels


Recommended Posts

Available for:


4.13.10 cubox (Cubox-i, Hummingboards)
4.13.10 mvebu64 (Espressobin)
4.9.58  odroidxu4 (Odroid XU3/XU4)
4.13.10 rockchip (Tinkerboard, MiQi)
4.13.10 sunxi (All Allwinner 32bit boards)
4.13.10 sunxi64 (All Allwinner 64bit boards)




- Armbian OS. Ubuntu or Debian bases.
- root credentials

Download: *dtb and *image packages at a minimum and install them with dpkg -i *.deb ... If you want to stay on this kernel, freeze upgrades in armbian-config -> system -> freeze kernel upgrades.

Remember that those kernels are bleeding edge, made from upstream sources and may have troubles. Consider them as is/experimental, without end-user support. If you want to build them - patches are present but .disabled and might not apply cleanly with more recent sources without adjustements.

What is RT?

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download


hi @Igor

thank you for the tip !

Did go and download XU4 RT kernel .debs installed and at reboot did not get usual blue-light kernel heart-beat.


Thought maybe something was wrong with my image (built using instructions) and i downloaded the one https://dl.armbian.com/odroidxu4/Ubuntu_xenial_next.7z burned, booted, all usual - added user, rebooted one more time and then installed realtime kernel.

When i power it on afterwards - same issue - blue light changes every 10-15seconds from off to on (no heaertbeat). can not ping it.

Is there a tested scenario where you did get RT kernel to work on that i could try to replicate please ?


thanks so much !


Link to comment
Share on other sites

1 hour ago, Igor said:

No, those are first testing build of RT kernel for XU4, not very well tested. I will try to look into this when possible.

Thanks Igor !

For what it is worth - i tried building it 2-3 weeks ago with then current RT-patch that is included in Armbian and yesterday with latest from rt-patches repository (for 4.9.61 kernel at https://www.kernel.org/pub/linux/kernel/projects/rt/4.9/patches-4.9.61-rt61.tar.gz ).

Either one (self built/latest) behave the same ... if it helps :)

thank you !

Link to comment
Share on other sites

hy Igor,

thanks for your information. Yesterday I switched to a RT kernel according to your instructions. My Thinkerboard work as a LogitechMediaServer with more then one squeezelite instance, librespot, MPD, shairplay, etc.

it works!


however, one thing does not work anymore the playback of my line input. it overrides and emits a very damaged sound.

this command worked fine with kernel 4.4.73-rockchip:

arecord -f S16_LE -c2 -r44100 -d 0 -D plug:dsnoop01 | aplay -B 1 -D plug:LineIn01 

I also tried csound but here I have the same problem.


my Kernel version now:




ask for info what could be the problem here and how I can solve it.



Link to comment
Share on other sites

  • Igor unpinned this topic
This topic is now closed to further replies.

  • Create New...