BPI-M2+ WiFi doesn't see control channel 13


Recommended Posts

Hi all!

 

I'm new to Armbian so share my experience in this section.

After several failures I managed to find an image that boots on my Banana Pi M2+ (Armbian_5.34.171121_Bananapim2plus_Debian_stretch_next_4.13.14_desktop).

Everything worked nicely from the box, thanks all developers for a great job (but indeed, huge penguin looks a bit frightening on 55" TV).

 

While setting up WiFi I found that the board doesn't "see" my AP (while all neighbours' were there). After playing with AP's settings i figured out that it's not visible if Control Channel is set to 13.  When I disabled autoselection of channel 13 on the AP, the board was able to connect.

My AP is ASUS RT-AC68U with Merlin, all settings for 2.4 GHz are set to Auto (except control channel selection now).

Current Armbian is 5.37.180112 nightly Debian GNU/Linux 9 (stretch) 4.14.13-sunxi.

 

So the question is could visibility of Channel 13 be fixed by configuration, or it's hardcoded in the AP6212 WiFi module?

Edited by Kalobok
Link to post
Share on other sites
Donate and support the project!

@tkaiser thanks for the hint.

 

Initially country is set to 00, and is changed with iw reg set:

anton@BPI-M2p:~$ sudo iw reg get
global
country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, NO-IR
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
        (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)

anton@BPI-M2p:~$ sudo iw reg set NL
anton@BPI-M2p:~$ sudo iw reg get
global
country NL: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

iw list shows band 13 as available:

                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)

However, if I switch my AP to Control Channel 13,  the board cannot see my AP. It seems that HW stays tuned to some other region. Unfortunately, I don't have enough knowledge to dig deeper.

 

Ah, and after reboot the region is back to 00.

 

Link to post
Share on other sites
7 hours ago, Kalobok said:

However, if I switch my AP to Control Channel 13,  the board cannot see my AP.

It seems that HW stays tuned to some other region. Unfortunately,

I don't have enough knowledge to dig deeper.

Ah, and after reboot the region is back to 00.

 

You could try to set your country for Wifi in the config-file

/etc/default/crda

 

As I know - in Germany - the Channel 13 is allowed. So you can try to set it to DE

Link to post
Share on other sites

Checked with legacy kernel (5.35 user-built Ubuntu 16.04.3 LTS 3.4.113-sun8i).

Country is also set to 00: DFS-UNSET,  but iw reg set NL has no effect, country remains set to 00.

The board, however, sees my AP on Control Channel 13 and successfully connects. So it's driver, not AP6212 chip.

 

After upgrading legacy to 5.36 reg set and reg get work.

 

@guidol, for upgraded legacy kernel setting region in /etc/default/crda works. Will check with mainline kernel later.

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.