Jump to content

USB ports are not working.


Recommended Posts



I have decided to try out Ubuntu 16.04 legacy on my original banana pi for the first time and to my surprise the first problem I noticed is that the usb ports weren't working at all. I tried two keyboards which are working fine on all my Linux computers all running on mint 18.3 (logiItech k360, and insignia nsc5011-c) they are both wireless keyboard + mouse combos they did not work at all on the banana.


I  previously had bananian on it prior to today and all usb ports were working fine as I was able to connect external usb hard drives to it.


I decided to connect the banana to my LAN and ssh to it from my laptop, did an apt update and apt upgrade, rebooted then tried again and they still did not work.

I then tried to connect my usb fat32 flash drive on one of the ports and nothing worked either.


FYI: My power supply is 5volts with 3.5 amperes.


I reconnected the banana to my LAN and sshed to it from my laptop, I plugged in the usb dongle for the logitech and it did not show up when I typed lsusb. Nothing I plugged in to the ports show up when I type `lsusb`


Please help. Thanks.

Link to comment
Share on other sites

Never mind folks, everything works great. It was my mistake, I powered on the banana via OTG instead of the 5v2A DC port. As soon as I realized this and used the proper power port for powering the device.


Edit: Nope, still still having the same issue. I thought for sure the 5v2A port would fix it but it didn't.

Link to comment
Share on other sites

Banana USB ports definitely work, however, there might be some problems in a recent legacy (3.4.y) build - not sure if they could be related to this. My first guess would be underpowering:

In any case, stick to the modern kernel and provide logs with:

armbianmonitor -u


Link to comment
Share on other sites

Could it be the way I copied the image to the micro SD that broke it?
I always used dcfldd for all my boards since it gives me progress output

sudo dcfldd if=~/Desktop/bananian_backup/Armbian_5.38_Bananapi_Ubuntu_xenial_default_3.4.113_desktop.img of=/dev/sdb bs=100M conv=notrunc statusinterval=1


How do you copy your image to the banana pi?

Link to comment
Share on other sites

I figured out what the problem was finally. But still unsatisfied.


I went back to bananian and checked to see if USB's worked for keyboard/mouse, they did not. I remembered I used a powered usb3 hub for bananian to get my external hard drives working. So I plugged the powered usb3 hub to the banana then plugged in the usb adapter for keyboard and mouse on the hub. They worked then. I'm guessing the  banana  isn't able to give enough power to power the mouse/keyboard adapter. I'm going to try armbian ubuntu again and see how things go.


This is the usb hub i used: https://www.amazon.ca/ORICO-Aluminum-12V2-5A-Adapter-3-3Ft/dp/B00BIDTU04


WIthout the hub, when I plug in the mouse/keyboard adapter I get the message: unable to enumerate usb device on port 1


Edit: I've confirmed that no power is going to the usb ports. I'm gonna go look through the banana pi m1 schematics to see if I can somehow do some soldering magic to route power from the microusb port to the USB ports.  Thanks for all the help.

Link to comment
Share on other sites

Conclusion update - for those who have similar problems.

I managed to successfully solve my problem. In conclusion, it was not a software but a hardware problem.  Turns out I had a blown capacitor and resistor that led the USB ports to be starved off power. Fixed it by cleaning off the burnt parts and re-soldering them after looking at the schematics to see what their purpose where. Now everything truly works perfectly.

See pics below, blown capacitor is circled in red.

Power schematic, shows where power flows to usbPower schematic, shows how power goes to usb ports L11 and L12

Screenshot from 2018-02-23 23-19-15.png


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines