1 1

SPDIF not working due to a bug in kernel 4.16.8, after Cubox-i4Pro Armbian Ubuntu upgraded from 5.38 to 5.44

Recommended Posts

Hello everyone,


just wanted to let you know, upgrade from Armbian Ubuntu 5.38 to 5.44 caused problems on my Cubox-i4Pro.

- Armbian Ubuntu 5.38 headless (no display connected to Cubox-i) worked perfectly, there were no issues with anything.

- Upgraded Armbian Ubuntu 5.38 to 5.44 (apt-get) and rebooted

- After reboot, no audio was sent to my audio amplifier (through Toslink optical cable) by Shairport-Sync 3.1.7 (AirPlay emulator). Airplay was visible on my iOS devices (iPad, iPhone) and audio was streamed from iOS to AirPlay, but no audio was sent by Cubox-i to the optical connection to my audio amplifier.

- Removed the Shairport package using dpkg -r

- Rebooted Cubox-i using command reboot, but Cubox-i not booting anymore, SSH connection not possible anymore, red LED on Cubox-i is off (I think the LED was off also on Armbian ver. 5.38)

- Unplugged the power cable, waited a minute, restored power, Cubox-i not booting, no SSH


I'll restore the system ver. 5.38 from my backup image.

Please let me know if I can be of any help.


Share this post

Link to post
Share on other sites
12 minutes ago, Igor said:

On which kernel? If I understand correctly ... Cubox booted to new system fine, only audio was missing?

First reboot after packages were upgraded to 5.44, Cubox-i booted, but no audio. After second reboot, Cubox-i did not boot anymore (no SSH).

I've just restored Armbian Ubuntu 5.38 from my backup image.

Upgraded only the package "linux-image-next-cubox 5.44", (armhf Linux kernel, version 4.16.8-cubox),  no other packages upgraded.

Cubox-i booted, but no audio on optical.

Just let me know if you need me to test anything else.

Share this post

Link to post
Share on other sites

I can see in the log:

Kernel 4.14.14:

[ 1.775033] imx-spdif sound-spdif: snd-soc-dummy-dai <-> 2004000.spdif mapping ok


Kernel 4.16.8:

[ 1.764797] imx-spdif sound-spdif: ASoC: CPU DAI (null) not registered

[ 1.764810] imx-spdif sound-spdif: snd_soc_register_card failed: -517

Share this post

Link to post
Share on other sites

Hello Igor,

after my Cubox-i was upgraded from Armbian 5.60 to 5.70 today, SPDIF audio output stopped working.




Armbian 5.70:

Operating system     Ubuntu Linux 18.04.1

Kernel and CPU     Linux 4.19.14-cubox on armv7l


SPDIF audio output used to work properly with Armbian 5.60 (kernel 4.14.70)


Please, let me know if I can be of any further help.

Thank you!

Share this post

Link to post
Share on other sites

I've restored Armbian 5.60 from SD backup image, upgraded to Armbian 5.70 (Kernel 4.19.14), rebooted. The same way as before. Now it works. Can't explain why it works now, but thank you anyway!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

1 1