Jump to content
  • 0

ClearfogPro - USB Serial Graphics (Was: U-Blox MPCI-L201 4g first connection help)



EDIT: This started off as a request for help starting up a 4G modem. After attempting to connect ANY network with nmtui, it's become also a request to configure a terminal such as 'screen' to be able to see the nmtui commands for any connection.


I recently acquired an U-Blox MPCI-L201 4g LTE modem. This is my first time attempting this type of connection and things are not as intuitive as I would hope so I thought I would reach out.


I downloaded the most recent Armbian Stretch from the downloads page and re-flashed the emmc. 

lsusb clearly shows the device

root@clearfogpro:~# lsusb
Bus 005 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 1546:1146 U-Blox AG 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm using screen in a command box on an XU4 with Hardkernel's 18.04 as the host.


I've had good results with nmtui on a fresh Armbian install to set up the initial network connection, so I thought I would give that a try. It looks like the modem shows 4 additional wired connections that are not there if the card is removed. But I have to move the cursor to get something to display -




If I move the cursor up and down it exposes the entries -




Choosing Activate reveals the four wired connections -




so it appears the hardware is 'working.' These entries only show if the device is in either of the mpci slots. 


But it gets more difficult to decipher from there. Attempting to select one of the wired connections and then the Activate button makes it impossible to figure out what's happening on the screen -




Armbian-config displays similarly so I'm assuming this particular problem is graphic oriented.




I booted the XU4 into an Armbian build and had similar results. I found some really detailed information on the screen command that, while really interesting, was basically useless for this issue as far as I can tell as I couldn't find any formatting parameters with the exception of the "-a" switch which I think should automatically try to format pages but it didn't make a difference.


Through trial and success I connected to my Hotspot so I updated and upgraded, but that made no difference. But now I can find its ip and connect via ssh, and nmtui is nice via ssh!




But armbian-config, although it appears to run properly, complains that it does not have internet although clearly it does -




As I tried several times I noted the asterisks (*) move to different wired connections under USB Ethernet. After connecting via SSH I noted the <Activate> button becomes <Deactivate> when highlighting a starred entry, verified with my WiFi hotspot.  (BUT how is the Eth1 active with nothing connected?)


So this leads me to ask a couple questions ...


a) How to get past this 'screen' issue. In the past I've noticed these graphic issues don't happen on an SSH session.  I was lucky to guess and type the passphrase of my wifi and get this connected. I tried unsuccessfully several times to guess and enter the info for one of the ethernet ports. 

I tried several different terminal emulators, all had weird display results. I really need to be controlling the device through the USB serial rather than ssh through a hotspot on my phone. Again, it was a good guess getting this connected and I don't want to try again to get onto my local wifi.


b) once I was able to SSH to the clearfog, armbian-config shows me there is an ethernet connection over USB0 along side the terminal connection - how can I connect to this? I know there is a way to have multiple IPs on an adapter in linux but I haven't tried that; the instructions I found seemed more complex than I wanted to dive into, although I'd bet there's a simple proper way to do this.




c) What's the proper, or a better, way to enable a new 4G modem? I read some cryptic notes about wvdial on a TV box and followed some google links to various docs but I'm not quite putting it together. (separate post) Or is it even an issue as it looks like it and the sim work together to "just connect?"


d) If it is connected, or when I get it connected, how to I determine what the details are such as its IP, etc? It appears that it 'just works' but I need to be able to reference it for networking and, well, learn something.


Thanks in advance for any advice offered.




Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

This topic is now closed to further replies.

  • Create New...