0
Merlin475

Need some serious help with FriendlyElec K2

Recommended Posts

Hello everyone,

First let's just say that I know this problem doesn't concern Armbian and I understand if no one help me or this topic get deleted.

 

I have been working with Nanopi K2 for a month to make it work with libreelec and I haven't had any luck so far, I'll share what I have done and hopefully someone who knows a lot more than I do and have the proper knowledge/skills can make this work.

 

There is an old version of Libreelec that work with K2 without any problem but it's really outdated and I'm looking for the latest version,

Here is the link for LE8.0 with kodi 17.1 for K2, (No H.265 support on this version, witch is all I need)

https://drive.google.com/uc?id=1xpZneTNXYi8TSOnWH5g6x7QA0jShGi4v&export=download

 

There is an option in LE for update and it kinda works but not really, it will download the file in link below and do some stuff but after rebooting it won't boot up, it's actually a black screen with no image at all.

http://archive.libreelec.tv/LibreELEC-S905.arm-8.90.007.tar

 

There is a same progress with writing this image on an empty SD card and patching it with this file,

http://piboard.io/assets/uploads/files/1496080309668-nanopi-k2-patch-by-kicker22004.tar.gz

This is also another patch that I guess it's the same as the one above since it won't work neither

https://forum.armbian.com/applications/core/interface/file/attachment.php?id=1132

I've found this patch on this forum and it only works with LE8.0 and older.

 

This is the output that I got from UART and there is no picture.

GXBB:BL1:08dafd:0a8993;FEAT:EDFC318C;POC:3;RCY:0;EMMC:800;NAND:81;SD:0;READ:0;CHK:0;
no sdio debug board detected 
TE: 177291
BL2 Built : 12:06:06, Jun 13 2016. 
gxb g176ecdb - laiyin.mo@droid12-sz
set vcck to 1100 mv
set vddee to 1000 mv
Board ID = 8
CPU clk: 1536MHz
DDR chl: Rank0+1 same @ 792MHz
DDR0: 2048MB(auto)-2T-11
DataBus test pass!
AddrBus test pass!
Load fip header from SD, src: 0x0000c200, des: 0x01400000, size: 0x00004000
New fip structure!
Load bl30 from SD, src: 0x00010200, des: 0x01000000, size: 0x0000d460
Sending bl30......................................................OK. 
Run bl30...
Load bl31 from SD, src: 0x00020200, des: 0x1010000[, size: 0x00013140
Image: gxb_v1.1.3134-b387442 2016-06-16 14:48:44 yun.cai@droid06]
OPS=0x13
77 6f c1 25 27 9e ab 53 12 f5 9d f6 [0.272593 Inits done]
secure task start!
high task start!
low task start!
Load bl33 from SD, src: 0x00034200, des: 0x01000000, size: 0x0006afc0
NOTICE:  BL3-1: v1.0(debug):c813a61
NOTICE:  BL3-1: Built : 14:47:05, Jun 16 2016
INFO:    BL3-1: Initializing runtime services
WARNING: No OPTEE provided by BL2 boot loader
ERROR:   Error initializing runtime service opteed_fast
INFO:    BL3-1: Preparing for EL3 exit to normal world
INFO:    BL3-1: Next image address = 0x1000000
INFO:    BL3-1: Next image spsr = 0x3c9
U-Boot 2015.01-00014-g4ef665ff6c-dirty (May 06 2017 - 20:32:09)
DRAM:  2 GiB
Relocation Offset is: 76f3b000
register usb cfg[1][0] = 0000000077f96b78
register usb cfg[0][1] = 0000000077f96b98
register usb cfg[2][0] = 0000000077f96bb8
vpu: error: vpu: check dts: FDT_ERR_BADMAGIC, load default parameters
vpu: clk_level = 7
vpu: set clk: 666667000Hz, readback: 666660000Hz(0x300)
MMC:   SDIO Port B: 0, SDIO Port C: 1
[mmc_init] mmc init success
In:    serial
Out:   serial
Err:   serial
reboot_mode=cold_boot
hpd_state=0
cvbs performance type = 4, table = 0
Net:   Meson_Ethernet
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
[OSD]check dts: FDT_ERR_BADMAGIC, load default fb_addr parameters
[OSD]fb_addr for logo: 0x3d800000
[OSD]check dts: FDT_ERR_BADMAGIC, load default fb_addr parameters
[OSD]fb_addr for logo: 0x3d800000
[CANVAS]addr=0x3d800000 width=5760, height=2160
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
There is no valid bmp file at the given address
Hit Enter or space or Ctrl+C key to stop autoboot -- :  3  2  1  0 
(Re)start USB...
USB0:   dwc_usb driver version: 2.94 6-June-2012
USB (1) peri reg base: c0000020
USB (1) use clock source: XTAL input, div: 1
USB (1) base addr: 0xc9100000
Force id mode: Host
dwc_otg: Highspeed device found !
scanning bus 0 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
** Bad device usb 0 **
Device: SDIO Port B
Manufacturer ID: 41
OEM: 3432
Name: SD16G 
Tran Speed: 50000000
Rd Block Len: 512
SD version 2.0
High Capacity: Yes
Capacity: 7.5 GiB
mmc clock: 40000000
Bus Width: 4-bit
reading s905_autoscript
1773 bytes read in 4 ms (432.6 KiB/s)
## Executing script at 01020000
reading kernel.img
9578496 bytes read in 529 ms (17.3 MiB/s)
reading uEnv.ini
197 bytes read in 4 ms (47.9 KiB/s)
reading /dtb.img
38576 bytes read in 6 ms (6.1 MiB/s)
ee_gate_off ...
## Booting Android Image at 0x01080000 ...
reloc_addr =73f55d20
copy done
load dtb from 0x1000000 ......
board_usb_stop cfg: 0
   Uncompressing Kernel Image ... OK
   kernel loaded at 0x01080000, end = 0x01a89b18
   Loading Ramdisk to 3fbd5000, end 3ffffc00 ... OK
   Loading Device Tree to 000000001fff3000, end 000000001ffff6af ... OK
Starting kernel ...
uboot time: 8648078 us

 

Additional info:

I have tried to use C2 images but it won't work and on UART it says that this board is not authorized. I used that patch still said unauthorized board.

I have tried to use Le potato image with the same patch it doesn't work neither.

I have tried bunch of their user compiled images for S905 boxes and generic image, no luck so far.

I have bought a ROC-RK3328-CC Firefly board but it turns out that has a major bug with HEVC and they are not releasing any new image anytime soon, I'm really frustrated now.

 

I have seen @TonyMac32 , @Neil Armstrong , @Igor  and some other users in here do some amazing work with K2 and C2 so I thought since Libreelec forum was a bust and no one helped me there, maybe I have better luck in here.

I'm not really experienced with this stuff but I can test different things if properly explained with enough details.

Thank you very much for reading this and helping me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0