0
Evgeny  Dmitrichenko

build image with hardware config and time zone

Recommended Posts

Hello

I use compile.sh and customize-image.sh to make my own custom image and every think is all right and work great.

This is my command line to compile:

sudo ./compile.sh 
KERNEL_CONFIGURE="no" 
KERNEL_ONLY="no" 
BOARD="orangepipc2"
BRANCH="next" 
RELEASE="xenial" 
BUILD_DESKTOP="yes" 

After burned my image and lounch Armbian I have to do two steps:

1) go to armbian config and set taggle hardware config "i2c0" option to "true" (like on picture 1.png)

2) go to armbian config and set time zone = Europe/Moscow

 

I tried to set KERNEL_CONFIGURE="yes" and try to find this options in configmenu = I did not find

I tried to add option TZDATA="Europe/Moscow" to command line = dose not work

 

What can I do to do this steps automaticaly in compile.sh or customize-image.sh?

 

1.png

Share this post


Link to post
Share on other sites
40 minutes ago, Evgeny Dmitrichenko said:

go to armbian config and set taggle hardware config "i2c0" option to "true" (like on picture 1.png)


Observe the difference in the /boot/armbianEnv.txt That you need to change in the build time if you want to have an image ready with those things applied.

 

40 minutes ago, Evgeny Dmitrichenko said:

go to armbian config and set time zone = Europe/Moscow


Use Google and search hot to set time zone in a script for Debian or Ubuntu. Xenial in your case as I can see. This is not an question for Armbian.
 

41 minutes ago, Evgeny Dmitrichenko said:

KERNEL_CONFIGURE="yes" and try to find this options in configmenu


Those are kernel features. Timezone is userspace feature which must be set with "customzite-image.sh" script. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0