0
madurani

Orange Pi R1 issue with second network interface eth1

Recommended Posts

Hello All,

 

I have configured OrangePiR1 as router. There are three network interfaces, two as wired and one wifi(hotspot). eth0 serve for access to internet(via ppp/adsl) and eth1+Wlan0 for internal network. Interfaces eth1 and wlan0 are in bridge br0.

Problem is, that interface eth1 sometimes loses connection/link(cable and switch were checked ).  Next nonstandard behavior of eth1 is, that only yellow led control is blinking, while green led control is not alight.

 

Network interfaces were configured via file /etc/network/interfaces. However, when I checked network manager nmcli, I saw, that some connections are configured there too (there can be some conflict).

Spoiler

 


root@kraken:~# cat /etc/network/interfaces
source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.100.2
netmask 255.255.255.0

auto dsl-provider
iface dsl-provider inet ppp
pre-up /bin/ip link set eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth1
allow-hotplug eth1
iface eth1 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wireless-power off

auto br0
iface br0 inet static
bridge_ports eth1 wlan0
address 192.168.1.1
netmask 255.255.255.0


root@kraken:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 02:42:d5:fc:e4:ba brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.2/24 brd 192.168.100.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::42:d5ff:fefc:e4ba/64 scope link 
       valid_lft forever preferred_lft forever
4: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state UP group default qlen 1000
    link/ether c0:74:2b:ff:ed:69 brd ff:ff:ff:ff:ff:ff
5: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 0c:8c:24:1d:6f:41 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br0
       valid_lft forever preferred_lft forever
    inet6 fe80::c274:2bff:feff:ed69/64 scope link 
       valid_lft forever preferred_lft forever
7: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br0 state UP group default qlen 1000
    link/ether 0c:8c:24:1d:6f:41 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e8c:24ff:fe1d:6f41/64 scope link 
       valid_lft forever preferred_lft forever
8: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
    link/ppp 
    inet xxx.xxx.xxx.xx peer xxx.xxx.xxx.xxx/xxx scope global ppp0
       valid_lft forever preferred_lft forever

   
root@kraken:~# nmcli con show
NAME             UUID                                  TYPE            DEVICE 
Ifupdown (eth0)  681b428f-beaf-8932-dce4-687ed5bae28e  802-3-ethernet  eth0   
br0              4e181b48-4c61-4810-a9a3-c65db0678450  bridge          br0    
eth1             b807144d-c7ea-4145-8c64-33ce78601d22  802-3-ethernet  eth1   
Ifupdown (eth1)  7b635ed6-2640-7ad8-675d-744db12dd9fa  802-3-ethernet  --   

  
root@kraken:~# ethtool eth1
Settings for eth1:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                             100baseT/Half 100baseT/Full 
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 32
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00007fff (32767)
                               drv probe link timer ifdown ifup rx_err tx_err tx_queued intr tx_done rx_status pktdata hw wol
        Link detected: yes

 

Edited by Tido
added spoiler

Share this post


Link to post
Share on other sites
2 hours ago, madurani said:

Problem is,

please post the  armbianmonitor -u  output

 

Look at the folder etc/network/  you find there several files. One is the master file. You can use  armbian-config to make changes to your settings.

 

Share this post


Link to post
Share on other sites

Here is output with link for downloading:

 

root@kraken:/etc/network# armbianmonitor -u  
System diagnosis information will now be uploaded to http://ix.io/1wPj

Main config file /etc/network/interfaces was edit manual, not via armbian-config, because there isn't possibility for raising of bridge.

Share this post


Link to post
Share on other sites
5 minutes ago, madurani said:

there isn't possibility for raising of bridge.

I haven't any armbian running right now, but IIRC there is an option in armbian-config to edit this file manually within armbian-config. Please check.

 

18 minutes ago, Tido said:

Look at the folder /etc/network/  you find there several files.

you might have a conflict because you have edited the 'wrong' one. So I recommend again above  edit this file manually within armbian-config

 

Share this post


Link to post
Share on other sites
32 minutes ago, Tido said:

I haven't any armbian running right now, but IIRC there is an option in armbian-config to edit this file manually within armbian-config. Please check.

 

you might have a conflict because you have edited the 'wrong' one. So I recommend again above  edit this file manually within armbian-config

 

I don't known to find in "armbian-config" nothing similar as "IIRC'. When I start mentioned tool and set up network part and pick up eth1, so there isn't any options for "bridge".

 

Yes it look on mishmash configuration, because AccessPoint was configured via "armbian-config" but bridge configuration were done via brctl and not via NM or armbian-config.

Probably turn off MN can solve this issue?

 

 

Share this post


Link to post
Share on other sites

Can somebody help me correctly configure two nodes bridge via network-manager or armbian-config? Node are wlan0 and eth1. 

Wlan0 is manages via  hostapd and configured was via "armbian-config". 

Bridge were configure manually in /etc/network/interfaces:

auto br0
iface br0 inet static
bridge_ports eth1 wlan0
address 192.168.1.1
netmask 255.255.255.0

But network-manager sees only one node eth1. Wlan0 isn't active/managed via NM:

 

root@kraken:~# nmcli con show
NAME                UUID                                  TYPE             DEVICE  
br0                 ea0b5fc2-c262-47a2-a1f8-7b186860d3ea  bridge           br0     
eth0                5df08611-abea-491c-af88-4733fba17e69  802-3-ethernet   eth0    
eth1                085af0b4-59e7-4a73-9498-2f363dec7398  802-3-ethernet   eth1    
Ifupdown (eth0)     681b428f-beaf-8932-dce4-687ed5bae28e  802-3-ethernet   --      
Ifupdown (eth1)     7b635ed6-2640-7ad8-675d-744db12dd9fa  802-3-ethernet   --      
bridge-slave-eth1   4d4c214f-ec45-4a23-b761-2437b4b9d9c8  802-3-ethernet   --      
bridge-slave-wlan0  0b158612-8aab-44bc-9cf8-691f8bbda227  802-11-wireless  --     

 

DEVICE  TYPE      STATE      CONNECTION  
br0     bridge    connected  br0         
eth0    ethernet  connected  eth0        
eth1    ethernet  connected  eth1        
lo      loopback  unmanaged  --          
ppp0    ppp       unmanaged  --          
wlan0   wifi      unmanaged  --         

Problem is, that eth1 sometimes loses link.

Next issue is, that only yellow led control is blinking on eth1, while green led control is not alight(short time during booting green led  light).

 

 

Share this post


Link to post
Share on other sites

I cannot help you from remote, but I would backup your config files and do fresh install of armbian.  Go to armbian-config / manual network configuration and paste there your config files. Then do testing / checks. Each line represents a command (except the ones with text which explains how to read the status of the connection here in color, click me )

bridge vlan show
bridge link show

ss -tua  Active Internet connections  or  netstat -tuap
ip r
ip link  (successor of ifconfig). 

UP it is administratively, the LOWER_UP indicates the physical layer is working (i.e. there is a carrier), and the second UP confirms (in effect) the IP layer is up. 

Cable plugged in:
3: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br0 state UP mode DEFAULT group default qlen 1000
  
Cable unplugged:
3: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br0 state LOWERLAYERDOWN mode DEFAULT group default qlen 1000

ifconfig -a
ifconfig eth0.101
brctl show
brctl showmacs br0
less /var/log/syslog  (type capital G to jump to last entry - q to exit)

 

By the way, I got my know how from the Lamobo R1 that uses nowadays DSA (Distributed Switch Architecture) and if your commands are for the old-school Bridge, but your device is on DSA... then you will have to change your approach.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0