0
InterAct

U-boot version question

Recommended Posts

Hi,

 

I've just created a SD-card with Armbian Bionic (mainline kernel 4.19.y) for a Hummingboard Gate. I noticed during boot that it says it uses U-boot version 2013.10-rc4. This seems quite old compared to the 2018 version that was on the Debian Stretch image from SolidRun. I've tried to search the internet to see what the impact of something like this is and wasn't able to find something that made sense to me (could be entirely my fault). I therefore have the question:

 

Is the U-boot version intentional? (maybe it has some features that newer versions have dropped.)

 

Share this post


Link to post
Share on other sites
1 hour ago, InterAct said:

Is the U-boot version intentional?


Yes. I tried several times to move on to new kernel u-boot, but out of my three Solidrun boards, only one could boot successfully. With the old kernel, they all boots. 

Share this post


Link to post
Share on other sites

Left one / single core:

U-Boot SPL 2018.01-armbian (Feb 06 2019 - 11:52:19)
SPL: Unsupported Boot Device!
Trying to boot from USB SDP
SDP: initialize...

Right one / quad core:

U-Boot 2018.01-armbian (Feb 06 2019 - 11:52:19 +0100)

CPU:   Freescale i.MX6Q rev1.5 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 23C
Reset cause: POR
Board: MX6 HummingBoard2
       Watchdog enabled
DRAM:  2 GiB
MMC:   FSL_SDHC: 0, FSL_SDHC: 1
MMC partition switch failed
*** Warning - MMC partition switch failed, using default environment

No panel detected: default to HDMI
Display: HDMI (1024x768)
In:    serial
Out:   serial
Err:   serial
MMC partition switch failed
!MMC partition switch failed

 

P1120420.JPG

P1120419.JPG

 

Cubox quad and Hummingboard v1 works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0