1 1
F4VSJ

OPI Lite wants to connect eth0

Recommended Posts

Hello,

I'm running a OPI Lite with debian jessie,

All works fine until i have to reboot, and that happens quiet often while testing software.

AFTER the boot i'm not able to reach the OPI via SSH, because the eth0 is activated ...and has a 169.x.x.x ip adress...

On the OPI Lite i can ONLY discover WIFI and no eth0 connector...So i go into the "nmtui" tool and "disactivate" the eth0...

Than i have access again via the wifi to my OPI lite.

How can i completely disable the eth0, that only WIFI connects to my network?

I didn't find about this behavior on the web, anyone else have that problem?

Kind regards from Hans F4VSJ

 

 

Share this post


Link to post
Share on other sites
3 hours ago, F4VSJ said:
All works fine until i have to reboot, and that happens quiet often while testing software.

AFTER the boot i'm not able to reach the OPI via SSH, because the eth0 is activated ...and has a 169.x.x.x ip adress...

On the OPI Lite i can ONLY discover WIFI and no eth0 connector...So i go into the "nmtui" tool and "disactivate" the eth0...

Than i have access again via the wifi to my OPI lite.

How can i completely disable the eth0, that only WIFI connects to my network?

 

I know the 169.x.x.x addresses only from Windows, when the Interface is set to DHCP, but here is no DHCP-Server.

I did found a way to deactivate eth0 via nmtui, but if you will try of the follwoing commands from the named url in the

/etc/rc.local before the command 'exit 0'

Page-URL: https://www.thegeekdiary.com/how-to-configure-and-manage-network-connections-using-nmcli/

find the part 'Example 2 : The nmcli connection up|down Commands'

 

First use the command to find the name of your connection:
 

# nmcli connection show
NAME         UUID                                  TYPE            DEVICE  
Wired_conn1  dba7561b-dd02-3b58-92c0-07ce94b6250f  802-3-ethernet  eth0   
Wired_conn2  bbe539aa-5042-4d28-a0e6-2a4d4f5dd744  802-3-ethernet  eth1

 and then add the follwing command for the name of your connection in your /etc/rc.local (before exit 0):
 

#  nmcli connection down id Wired_conn1
Connection 'Wired_conn1' successfully deactivated

PS: # is the root-prompt - dont use it in /etc/rc.local because then it will be a commentar :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1