spikerguy

Members
  • Content Count

    6
  • Joined

  • Last visited

About spikerguy

  • Rank
    Newbie

Contact Methods

  • Website URL
    fkardame.com

Profile Information

  • Gender
    Male
  • Location
    Bahrain

Recent Profile Visitors

80 profile views
  1. Can you please post the content of both the files? I am not sure so it will be better to read the content and understand what it is trying to do, AFAIK I have been using the latest iteration of the install script which includes support for RGB YUV for aml devices which have green screen issue.
  2. I have the same issue, Here is my uart output when the device locks up. ``` fuse: init (API version 7.31) [ 157.006866] SError Interrupt on CPU5, code 0xbf000000 -- SError [ 157.006872] CPU: 5 PID: 1115 Comm: [ 157.006875] Hardware name: Beelink GT-King Pro (DT) [ 157.006878] pstate: 80000005 (Nzcv daif -PAN -UAO) [ 157.006881] pc : _raw_spin_unlock_irqrestore+0xc/0x68 [ 157.006883] lr : add_wait_queue+0x50/0x68 [ 157.006885] sp : ffff800015943940 [ 157.006888] x29: ffff800015943940 x28: 0000000000000019 [ 157.006894] x27: ffff800015943abc x26: ffff0000877a1800 [ 157.006900] x25: 0000000000000020 x24: ffff0000877a1801 [ 157.006906] x23: 0000000000000000 x22: ffff00000533f000 [ 157.006911] x21: ffff00000533f038 x20: ffff00008b561d40 [ 157.006916] x19: ffff00000533f020 x18: 00000000000000c0 [ 157.006921] x17: 0000000000000000 x16: 0000000000000000 [ 157.006927] x15: 0000000000000000 x14: dead000000000122 [ 157.006932] x13: ffffffffffffffff x12: fffffdfffff4df48 [ 157.006937] x11: 0000000000000191 x10: 0000000000000000 [ 157.006942] x9 : 0000000000000000 x8 : ffff800012931cc0 [ 157.006947] x7 : 0000000000000000 x6 : ffff0000b8ff9b70 [ 157.006953] x5 : ffff8000129321c0 x4 : 0000000000000000 [ 157.006958] x3 : ffff00008b561d48 x2 : 0000000000000000 [ 157.006963] x1 : 0000000000000000 x0 : ffff00008b561d40 [ 157.006970] Kernel panic - not syncing: Asynchronous SError Interrupt [ 157.006974] CPU: 5 PID: 1115 Comm: [ 157.006977] Hardware name: Beelink GT-King Pro (DT) [ 157.006979] Call trace: [ 157.006981] dump_backtrace+0x0/0x1c8 [ 157.006983] show_stack+0x18/0x28 [ 157.006985] dump_stack+0xb8/0x100 [ 157.006987] panic+0x15c/0x330 [ 157.006989] nmi_panic+0x8c/0x90 [ 157.006992] arm64_serror_panic+0x78/0x84 [ 157.006994] do_serror+0x84/0x140 [ 157.006996] el1_error+0x8c/0x108 [ 157.006999] _raw_spin_unlock_irqrestore+0xc/0x68 [ 157.007001] __pollwait+0xc8/0x100 [ 157.007003] rfkill_fop_poll+0x6c/0x70 [rfkill] [ 157.007006] do_sys_poll+0x28c/0x550 [ 157.007008] __arm64_sys_ppoll+0xb4/0xe8 [ 157.007011] el0_svc_common.constprop.0+0x74/0x1f0 [ 157.007013] do_el0_svc+0x24/0x90 [ 157.007015] el0_sync_handler+0x178/0x2b8 [ 157.007017] el0_sync+0x158/0x180 [ 157.007049] SMP: stopping secondary CPUs [ 157.007052] Kernel Offset: disabled [ 157.007054] CPU features: 0x080002,20082004 [ 157.007057] Memory Limit: none ``` It is a kernel panic caused by an unidentified interrupt. I hope someone can advice on what could be wrong with the dtb. Thanks.
  3. I have getting something similar ``` U-Boot SPL 2020.04-armbian (Jun 15 2020 - 04:07:06 +0200) DRAM: 1024 MiB Trying to boot from MMC1 MMC: no card present spl: mmc init failed with error: -123 SPL: failed to boot from all boot devices ### ERROR ### Please RESET the board ### ``` Now I cannot even boot into other os. Only the one on the emmc and I was just testing. Can anyone advice what is causing this ? I think it must be hardware issue. Thanks for the information above. Looks like my pin isn't working patching the uboot with the given config fixed the boot process but still it is not able to read the card further. ``` U-Boot 2020.04-2 (Jun 21 2020 - 22:22:21 +0000) Manjaro ARM CPU: Allwinner H5 (SUN50I) Model: FriendlyARM NanoPi NEO Plus2 DRAM: 1 GiB MMC: Device 'mmc@1c11000': seq 1 is in use by 'mmc@1c10000' mmc@1c0f000: 0, mmc@1c10000: 2, mmc@1c11000: 1 Loading Environment from FAT... Unable to use mmc 1:0... In: serial Out: serial Err: serial Net: phy interface7 eth0: ethernet@1c30000 starting USB... Bus usb@1c1a000: USB EHCI 1.00 Bus usb@1c1a400: USB OHCI 1.0 Bus usb@1c1d000: USB EHCI 1.00 Bus usb@1c1d400: USB OHCI 1.0 scanning bus usb@1c1a000 for devices... 1 USB Device(s) found scanning bus usb@1c1a400 for devices... 1 USB Device(s) found scanning bus usb@1c1d000 for devices... 1 USB Device(s) found scanning bus usb@1c1d400 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Hit any key to stop autoboot: 0 MMC: no card present switch to partitions #0, OK mmc1(part 0) is current device ** No partition table - mmc 1 ** Device 0: unknown device ethernet@1c30000 Waiting for PHY auto negotiation to complete......... TIMEOUT ! BOOTP broadcast 1 BOOTP broadcast 2 BOOTP broadcast 3 BOOTP broadcast 4 BOOTP broadcast 5 BOOTP broadcast 6 BOOTP broadcast 7 BOOTP broadcast 8 BOOTP broadcast 9 BOOTP broadcast 10 BOOTP broadcast 11 BOOTP broadcast 12 BOOTP broadcast 13 BOOTP broadcast 14 BOOTP broadcast 15 BOOTP broadcast 16 BOOTP broadcast 17 Retry time exceeded; starting again missing environment variable: pxeuuid missing environment variable: bootfile Retrieving file: pxelinux.cfg/01-02-01-45-1c-d4-60 ethernet@1c30000 Waiting for PHY auto negotiation to complete......... TIMEOUT ! *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/00000000 ethernet@1c30000 Waiting for PHY auto negotiation to complete......... TIMEOUT ! *** ERROR: `serverip' not set missing environment variable: bootfile Retrieving file: pxelinux.cfg/0000000 ethernet@1c30000 Waiting for PHY auto negotiation to complete....... ``` So mmc was not initiating Then I pressed the metal casing against the pin to make it touch the base pic and not the moving pin and now It can read the sd card fine. Hope this wont break again. This thread was so helpful without it user might have been thinking that is some hardware issue with the boards sd card slot. Thanks Again.
  4. spikerguy

    spikerguy

  5. Thanks alot. Megi is genius Ill make sure I follow the build script next time. Cheers.
  6. Yes done that thanks for the reply. Any idea about kernel source for NeoPlus2 ? Thanks.
  7. May I know who is maintaining support for Neo Plus2 ? I see it is under No Official Support (CSC) but I see Buster Server Supported is Ticked. I am not sure what that means AFAIK "No Official Support" means there is some community support available so maybe I can collaborate with the person supporting it. I have recently ordered it and plan to build my own kernel from the source. Can help in testing and maintaining the board support as long as it is alive Thanks.