mradalbert

Validating
  • Content Count

    8
  • Joined

  • Last visited

About mradalbert

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. You can track updates on Collabora blog. In last update they added early, partial support for OpenGL ES 2 in Bifrost. They confirmed GNOME 3 working on G31 but it is premature and can prove to be buggy.
  2. Try following this tutorial: If you want to boot from microSD basically you need to 1) burn desired image on the card (I suggest using Etcher) 2) Edit uEnv.txt for Amlogic and link DTB file (finding correct one requires a bit of try and error, I'm no expert but maybe start with meson-sm1-sei610.dtb) 3) Boot using toothpick method. Good luck!
  3. Vontar x3 (Amlogic S905X3 SoC) Most probably same circuit as H96 Max X3 see: Confirmed to work with h96max-x2-test-bus80-gpu-volt.dtb from root-stas: -HDMI w/ sound -WiFi 802.11a/b/g/n/ac -Bluetooth 4.0 after adding missing files Not working yet GPU/VPU accel
  4. I use different device but getting first armmian boot was difficult for me too. Try to burn card using Etcher and be aware that using toothpick method can be picky in terms of how long you press reset button.
  5. If you want to make it cheap take a look at here: Some people on 4pda.ru say that there are few devices that are electrically the same. They can be obtained from $35 for 2GB RAM and 4 GB for 5 more bucks. From my experience on my Vontar x3 everything works as on H96 Max x3. Currently most annoying is lack of gpu/vpu acceleration on Armbian. I'm experiencing some display issues but it's probably due to s905x3 incompatibility. On my hardware 2.4 GHz WiFi has crappy range but again "some people on 4pda" say that is due to inference from board and can be solved by using alumini
  6. About 1440p HDMI issue I tried do manually decode EDID and I found unlisted resolutions there. Whats more in Xorg logs I saw them as well. Anyway when I tried to set res manually (params taken from EDID and Xorg) from xrandr I got error: "Configure crtc 0 failed" and "failed to set mode: Invalid argument" in Xorg logs. This is the case to for all resolutions unlisted in xrandr that I tried (1080p75Hz doesn't work so it's not HDMI bandwidth fault or somerhing). @root-stas I can't locate Xorg.conf, some net sources say it's depreciated and must be created manually. At this point I don't know if
  7. Hi guys! People on 4pda say that H96 Max x3, Vontar x3, HK1 Box and Transpeed X3 Air are the same hardware (last three even look the same ). I tried using @root-stas dtb file and it worked on Vontar x3. So I suggest to change topic name to include other boxes names - maybe that will gather more people in this thread. As of me expect known bugs my device can not detect all resolutions over HDMI. I have 1440p 75 Hz monitor and Armbian can detect only resolutions up to 1080p at 60 Hz. I'm experiencing color shifts as well. Most looks about right but grays are shifted towards yellowish red. If s
  8. Hi guys, I'm all new to Armbian. I'm trying to boot Armbian_20.02.0-rc1.038_Aml-s9xxx_eoan_current_5.5.0-rc6_desktop_20200205 on tv box Vontar X3 (Amlogic s905x3). I tried to set meson-sm1-sei610.dtb in uEnv.txt without success. Then I extracted DTB ftom my device boot.img using this tool. Unfortunately extracted DTB file did not help. I'm always getting error message in recovery: Supported API: 3 charge_status 2, charged 1, status SUCCESS, capacity 100 Finding update package... Opening update package... E:Block map file is too short: 3 E:Map of '@/cache/recovery/block.map' faile