gewoonmaarten

Members
  • Content Count

    6
  • Joined

  • Last visited

About gewoonmaarten

  • Rank
    Newbie

Profile Information

  • Location
    Netherlands

Recent Profile Visitors

493 profile views
  1. SOLVED. I got the ethernet ports running using the dev branch of Armbian for the Clearfog then I bridged all the lan port to br0. Then I installed a dhcp server listing to br0. For more detail visit http://superuser.com/questions/1120714/how-make-a-switch-in-linux where its explained very clearly.
  2. yeah I think I found the problem. I couldn't load the mv88e6xxx_drv module in /etc/modules. I also tried the modules in this link: http://cateee.net/lkddb/web-lkddb/NET_DSA_MV88E6XXX.html but with the same result. I send an email to SolidRun and waiting for there response ( hopefully I get something useful but i highly doubt that). I am using latest vanilla jessie server from armbian for the clearfog pro. EDIT 1: after updating to the dev branch the module became available. EDIT 2: okay I have setup a bridge with lan1-lan6 as bridge ports and gave the bridge an IP address. But now I'm completely lost. I thought that the device behind lan1 would show up on my router but that appears not to be the case. Am I doing something wrong or is my understanding of bridges flawed? How do I communicate to the device behind lan1?
  3. Are you using the clearfog pro? If so could you provide the steps it took to get it the switch working. And what image did you use?
  4. I tried it on: root@armada:~# ping 192.168.177.2 PING 192.168.177.2 (192.168.177.2) 56(84) bytes of data. From 192.168.177.1 icmp_seq=1 Destination Host Unreachable From 192.168.177.1 icmp_seq=2 Destination Host Unreachable From 192.168.177.1 icmp_seq=3 Destination Host Unreachable ^C --- 192.168.177.2 ping statistics --- 5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4002ms pipe 3 root@armada:~# uname -a Linux armada 4.7.3-marvell #25 SMP Wed Sep 14 19:24:33 CEST 2016 armv7l armv7l armv7l GNU/Linux And on 4.4.20. But at this point I am worrying that I'm doing something wrong so i would like to go over the configurations I made. this is a list of thing I change. apt-get update && apt-get upgrade enable ip forwarding in /etc/sysctl.conf adding this config to /etc/network/interfaces auto eth1 iface eth1 inet static address 192.168.177.1 netmask 255.255.255.0 perform a reboot on the computer connected to the clearfog I create a static IP like this auto eth0 iface eth0 inet static address 192.168.177.2 netmask 255.255.255.0 gateway 192.168.177.1 and perform a reboot and then on the clearfog I try pinging 192.168.177.2 but it always gets lost. I was wondering if these are the right settings
  5. hmm that did not work for me. did anyone get it working? Does it work on the official debian SolidRun distro?
  6. Hi everyone, So I am a real beginner with networking so I though I would buy this board for learning and messing about. But I cant get the switched 6 port Ethernet to work. It shows up with ip link: root@armada:~#ip link 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 2: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 0a:b2:e1:6c:82:2e brd ff:ff:ff:ff:ff:ff 3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 532 link/ether 00:50:43:25:fb:84 brd ff:ff:ff:ff:ff:ff 4: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 532 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 5: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 532 link/ether 00:50:43:0d:19:18 brd ff:ff:ff:ff:ff:ff 6: tunl0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default qlen 1 link/ipip 0.0.0.0 brd 0.0.0.0 7: lan1@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 8: lan2@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 9: lan3@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 10: lan4@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 11: lan5@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff 12: lan6@eth1: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether 00:50:43:84:25:2f brd ff:ff:ff:ff:ff:ff I also can a assign an IP to eth1 and ping it, but i cant ping any thing connected with eth1. I am running the latest vanilla version of armbian for the Clearfog Pro. Help would be much appreciated.