edupv

Members
  • Content count

    13
  • Joined

  • Last visited

About edupv

Recent Profile Visitors

275 profile views
  1. Armbian for OrangePi PC2, AllWinner H5

    Yes, you can run these commands in /etc/rc.local. Moreover, the above may not be the best values for up_threshold/sampling_rate. You can test different values yourself.
  2. Armbian for OrangePi PC2, AllWinner H5

    You can adjust these 2 parameters, for example : echo 65 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold echo 50000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate Then CPU clock will go to 408MHz when idle.
  3. Thanks for your reply. I don't know C language, so I seldom check the source code. After reading your reply, I tested the timeout with a script. Yes, it is really 16 seconds. Thanks again for your help.
  4. I think 16 seconds is the max. value of the watchdog timeout of H2/H3, However, I cannot set it to 16 seconds. When watchdog-timeout = 16 in /etc/watchdog.conf, the timeout is 11 seconds : /etc/watchdog.conf max-load-1 = 24 watchdog-device = /dev/watchdog realtime = yes priority = 1 watchdog-timeout = 16 interval = 3 root@orangepizero:~# systemctl status watchdog.service ● watchdog.service - watchdog daemon Loaded: loaded (/lib/systemd/system/watchdog.service; enabled; vendor preset: enabled) Active: active (running) since Mon 2018-01-29 11:10:27 HKT; 3min 31s ago Process: 851 ExecStart=/bin/sh -c [ $run_watchdog != 1 ] || exec /usr/sbin/watchdog $watchdog_options (code=exited, status=0/SUCCESS) Process: 835 ExecStartPre=/bin/sh -c [ -z "${watchdog_module}" ] || [ "${watchdog_module}" = "none" ] || /sbin/modprobe $watchdog_module (code=exited, status=0/SUCCESS) Main PID: 855 (watchdog) CGroup: /system.slice/watchdog.service └─855 /usr/sbin/watchdog Jan 29 11:10:27 orangepizero watchdog[855]: int=3s realtime=yes sync=no soft=no mla=24 mem=0 Jan 29 11:10:27 orangepizero watchdog[855]: ping: no machine to check Jan 29 11:10:27 orangepizero watchdog[855]: file: no file to check Jan 29 11:10:27 orangepizero systemd[1]: Started watchdog daemon. Jan 29 11:10:27 orangepizero watchdog[855]: pidfile: no server process to check Jan 29 11:10:27 orangepizero watchdog[855]: interface: no interface to check Jan 29 11:10:27 orangepizero watchdog[855]: temperature: no sensors to check Jan 29 11:10:27 orangepizero watchdog[855]: test=none(0) repair=none(0) alive=/dev/watchdog heartbeat=none to=root no_act=no force=no Jan 29 11:10:27 orangepizero watchdog[855]: watchdog now set to 11 seconds Jan 29 11:10:27 orangepizero watchdog[855]: hardware watchdog identity: sunxi_wdt root@orangepizero:~# When watchdog-timeout = 7 in /etc/watchdog.conf, the timeout becomes 6 seconds : /etc/watchdog.conf max-load-1 = 24 watchdog-device = /dev/watchdog realtime = yes priority = 1 watchdog-timeout = 7 interval = 3 root@orangepizero:~# systemctl status watchdog.service ● watchdog.service - watchdog daemon Loaded: loaded (/lib/systemd/system/watchdog.service; enabled; vendor preset: enabled) Active: active (running) since Mon 2018-01-29 11:16:49 HKT; 1min 12s ago Process: 846 ExecStart=/bin/sh -c [ $run_watchdog != 1 ] || exec /usr/sbin/watchdog $watchdog_options (code=exited, status=0/SUCCESS) Process: 823 ExecStartPre=/bin/sh -c [ -z "${watchdog_module}" ] || [ "${watchdog_module}" = "none" ] || /sbin/modprobe $watchdog_module (code=exited, status=0/SUCCESS) Main PID: 849 (watchdog) CGroup: /system.slice/watchdog.service └─849 /usr/sbin/watchdog Jan 29 11:16:49 orangepizero watchdog[849]: int=3s realtime=yes sync=no soft=no mla=24 mem=0 Jan 29 11:16:49 orangepizero watchdog[849]: ping: no machine to check Jan 29 11:16:49 orangepizero watchdog[849]: file: no file to check Jan 29 11:16:49 orangepizero systemd[1]: Started watchdog daemon. Jan 29 11:16:49 orangepizero watchdog[849]: pidfile: no server process to check Jan 29 11:16:49 orangepizero watchdog[849]: interface: no interface to check Jan 29 11:16:49 orangepizero watchdog[849]: temperature: no sensors to check Jan 29 11:16:49 orangepizero watchdog[849]: test=none(0) repair=none(0) alive=/dev/watchdog heartbeat=none to=root no_act=no force=no Jan 29 11:16:49 orangepizero watchdog[849]: watchdog now set to 6 seconds Jan 29 11:16:49 orangepizero watchdog[849]: hardware watchdog identity: sunxi_wdt root@orangepizero:~# How can I set the watchdog timeout to 16 seconds ? Thanks.
  5. Thanks for your reply, but I have not bridged eth0 and wlan0 : root@bananapi:~# brctl show bridge name bridge id STP enabled interfaces br0 8000.983b16c7cd8d no wlan0 root@bananapi:~# I set up br0 because I have ordered an USB NIC (eth1) and I am going to add it to br0 later.
  6. I have tried to set up a Banana Pi M1+ as a wireless router (installed Armbian_5.35_Bananapi_Ubuntu_xenial_next_4.13.16 ). Existing set up and testing environment are as following: Now, my android phone can access the internet and the Banana Pi works as expected. However, when I checked the file /var/log/syslog of the x86 router, I found : Jan 20 00:12:51 router86 kernel: [25688.378214] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.378253] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.378422] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.378433] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.379413] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.379426] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.379573] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.379582] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.380656] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.380668] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.380817] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.380827] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.382479] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.382489] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.382693] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.382703] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.382911] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.382920] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. Jan 20 00:12:51 router86 kernel: [25688.415770] IPv4: martian source 104.17.115.27 from 10.111.103.154, on dev br0 Jan 20 00:12:51 router86 kernel: [25688.415809] ll header: 00000000: 00 e0 4c 68 12 86 02 d4 09 42 7c 37 08 00 ..Lh.....B|7.. The internal IP of my phone (10.111.103.154) behind the Banana Pi leaked to the external x86 router ! How can I fix this ? Thanks.
  7. Armbian for OrangePi PC2, AllWinner H5

    Please try this : https://github.com/igorpecovnik/lib
  8. Armbian for OrangePi PC2, AllWinner H5

    @tkaiser The situation happened in Armbian_5.26.170215_Orangepipc2_Ubuntu_xenial_dev_4.10.0. I upgrade my system by apt-get everyday, so I think my system is uptoday now. Here is the result I just tested. My PC2 was idle during the test : root@orangepipc2:~# armbianmonitor -m # <== using ondemand Stop monitoring using [ctrl]-[c] Time CPU load %cpu %sys %usr %nice %io %irq CPU 01:10:15: 480MHz 0.10 3% 1% 1% 0% 0% 0% 23.6°C 01:10:20: 480MHz 0.09 3% 1% 1% 0% 0% 0% 23.8°C 01:10:25: 480MHz 0.08 3% 1% 1% 0% 0% 0% 23.5°C 01:10:30: 480MHz 0.08 3% 1% 1% 0% 0% 0% 23.9°C 01:10:35: 480MHz 0.07 3% 1% 1% 0% 0% 0% 24.2°C 01:10:40: 480MHz 0.06 3% 1% 1% 0% 0% 0% 26.2°C 01:10:45: 480MHz 0.06 3% 1% 1% 0% 0% 0% 24.9°C 01:10:50: 480MHz 0.05 3% 1% 1% 0% 0% 0% 24.2°C 01:10:55: 480MHz 0.05 3% 1% 1% 0% 0% 0% 24.8°C 01:11:00: 480MHz 0.05 3% 1% 1% 0% 0% 0% 23.6°C^C root@orangepipc2:~# echo schedutil > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor root@orangepipc2:~# armbianmonitor -m Stop monitoring using [ctrl]-[c] Time CPU load %cpu %sys %usr %nice %io %irq CPU 01:11:28: 1296MHz 0.03 2% 1% 1% 0% 0% 0% 28.0°C 01:11:33: 1296MHz 0.02 2% 1% 1% 0% 0% 0% 29.0°C 01:11:38: 1296MHz 0.02 2% 1% 1% 0% 0% 0% 29.0°C 01:11:43: 1296MHz 0.02 2% 1% 0% 0% 0% 0% 29.0°C 01:11:48: 1296MHz 0.02 2% 1% 0% 0% 0% 0% 29.1°C 01:11:53: 480MHz 0.02 2% 1% 0% 0% 0% 0% 24.8°C 01:11:58: 1296MHz 0.02 2% 1% 0% 0% 0% 0% 29.1°C 01:12:03: 1296MHz 0.01 2% 1% 0% 0% 0% 0% 30.0°C 01:12:08: 1296MHz 0.01 2% 1% 0% 0% 0% 0% 30.5°C 01:12:13: 1296MHz 0.01 2% 1% 0% 0% 0% 0% 30.5°C 01:12:18: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 28.9°C 01:12:23: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 31.8°C 01:12:28: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 31.3°C 01:12:33: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 31.6°C 01:12:38: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 31.0°C 01:12:43: 1296MHz 0.01 2% 0% 0% 0% 0% 0% 32.3°C 01:12:49: 1296MHz 0.00 2% 0% 0% 0% 0% 0% 30.6°C 01:12:54: 1296MHz 0.00 2% 0% 0% 0% 0% 0% 32.2°C^C root@orangepipc2:~#
  9. Armbian for OrangePi PC2, AllWinner H5

    Are you using the default schedutil governor ? I am using my PC2 started from 170215 build, the behavior of schedutil governor was strange. It ramp up to 1296MHz when idle, but it went down to 480MHz under light load (e.g. apt-get update). Sometimes, after some loading, it became more normal - More 480MHz and less 1296MHz. Then, I changed the governor to ondemand. ondemand is "lazy" by default, and needs tuning to make it responsive : echo 25 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold echo 50880 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate I am happy with the ondemand governor and have not tried schedutil again.
  10. @praveenbm5 : 1. Load module twice : already done it according to your guide. 2. As long as I change the "wifi-device" and "option device" to 'wlan0' (I used 'radio0' before), scanning works in Luci, no matter what the "option path" is. 3. AP is not working, wireless client is not working too.
  11. Thanks for your information. Here is my lsusb -t output : root@pizero:~# lsusb -t /: Bus 08.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ohci/1p, 12M /: Bus 07.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ohci/1p, 12M /: Bus 06.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ohci/1p, 12M /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ohci/1p, 12M /: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ehci/1p, 480M /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ehci/1p, 480M /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ehci/1p, 480M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=sunxi-ehci/1p, 480M After checking a few openwrt routers' /etc/config/wireless, I think the "option path" is one of the subdirectory under /sys/devices, so I tried : option type 'mac80211' option path "platform/xradio_pm.0" # also tried "platform/wifi_pm.0" I also copied /lib/netifd/wireless/mac80211.sh from another other router (due to the error message from "wifi" command). With all the mentioned steps, wifi is still not working, and the operating frequency, mode, band, channel, width are not displayed in the Luci wifi config page. It seems that openwrt cannot read such information from the Wifi device.
  12. I created a /etc/config/wireless file manually, then reboot. After that the "Wifi" menu item appeared under the "Network" menu. I also installed wpa-supplicant & hostapd (according to the hints in the wifi config page), but wifi is still not working.
  13. I have a BananaPi M1+ running pure-ftpd, it was fine when using Armbian 5.14, but I have a problem after upgraded to Armbian 5.20. Here is the output of the filezilla client : If I disable the firewall by clearing all the iptables rules, filezilla can connect to pure-ftpd without problem.