Jump to content

atula

Members
  • Posts

    46
  • Joined

  • Last visited

Recent Profile Visitors

2339 profile views
  1. tested and works rkspi_loader-v20.11.2-trunk-v2.img Kingston A2000 M.2 2280 PCIe NVMe Gigabyte SSD M.2 2280 PCIe x2 Model:GP-GSM2NE8128GNTD Kingston 240GB A1000 SSD = PHISON PS5008-E8-10 Samsung 250GB 970 EVO Plus SSD-levy, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s Intel SSD 660p Model:SSDPEKNW512GB PNY 250GB XLR8 CS3030 M.2 NVMe SSD PCIe Gen3 x4 5.9.11 also old 4.4.213 boot from spi
  2. Thank you for very nice work! ~# dd if=rkspi_loader-v20.11.2-trunk-v2.img of=/dev/mtdblock0 bs=4K 1016+0 records in 1016+0 records out 4161536 bytes (4.2 MB, 4.0 MiB) copied, 67.6658 s, 61.5 kB/s Armbian 20.11.1 Buster ttyS2 rockpi-4a login: U-Boot TPL 2020.07-armbian (Dec 04 2020 - 22:10:39) Channel 0: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB Channel 1: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB 256B stride 256B stride lpddr4_set_rate: change freq to 400000000 mhz 0, 1 lpddr4_set_rate: change freq to 800000000 mhz 1, 0 Trying to boot from BOOTROM Returning to boot ROM... U-Boot SPL 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) Trying to boot from SPI NOTICE: BL31: v1.3(debug):42583b6 NOTICE: BL31: Built : 07:55:13, Oct 15 2019 NOTICE: BL31: Rockchip release version: v1.1 INFO: GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3 INFO: Using opteed sec cpu_context! INFO: boot cpu mask: 0 INFO: If lpddr4 need support multi frequency, INFO: please update loader! INFO: Current ctl index[0] freq=400MHz INFO: Current ctl index[1] freq=800MHz INFO: plat_rockchip_pmu_init(1190): pd status 3e INFO: BL31: Initializing runtime services WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK ERROR: Error initializing runtime service opteed_fast INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x200000 INFO: SPSR = 0x3c9 U-Boot 2020.07-armbian (Dec 04 2020 - 22:10:39 +0100) SoC: Rockchip rk3399 Reset cause: POR Model: Radxa ROCK Pi 4B DRAM: 3.9 GiB PMIC: RK808 MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0 Loading Environment from SPI Flash... SF: Detected w25q64cv with page size 256 Bytes, erase size 4 KiB, total 8 MiB *** Warning - bad CRC, using default environment In: serial Out: serial Err: serial Model: Radxa ROCK Pi 4B Net: eth0: ethernet@fe300000 Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc1 is current device Scanning mmc 1:1... Found U-Boot script /boot/boot.scr 3185 bytes read in 6 ms (517.6 KiB/s) ## Executing script at 00500000 Boot script loaded from mmc 1 251 bytes read in 4 ms (60.5 KiB/s) 13478362 bytes read in 574 ms (22.4 MiB/s) 27574784 bytes read in 1169 ms (22.5 MiB/s) 74167 bytes read in 12 ms (5.9 MiB/s) 1314 bytes read in 10 ms (127.9 KiB/s) Applying kernel provided DT overlay rockchip-spi-jedec-nor.dtbo 2698 bytes read in 10 ms (262.7 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) ## Executing script at 09000000 ## Loading init Ramdisk from Legacy Image at 06000000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 13478298 Bytes = 12.9 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ## Flattened Device Tree blob at 01f00000 Booting using the fdt blob at 0x1f00000 Loading Ramdisk to f1237000, end f1f1199a ... OK Loading Device Tree to 00000000f11bc000, end 00000000f1236fff ... OK Starting kernel ...
  3. something väärin järjestelmissäni root @ rockpi-4a: / boot # dd if = rkspi_loader-v20.11.2-trunk.img / = dev / mtdblock0 bs = 4K 1016 + 0 tietuetta 1016: ssa + 0 tietuetta kopioitu 4161536 tavua (4,2 Mt, 4,0 Mt) , 70,186 s, 59,3 kB / s U-Boot SPL 2020.07-armbian (03.12.2020 - 21:19:03 +0100) Käynnistysyritys MMC1- kortilta ei vastannut jännitteen valintaan! spl: mmc init epäonnistui virheellä: -95 Käynnistäminen MMC2- kortilta ei vastannut jännitteen valintaan! spl: mmc init epäonnistui virheellä: -95 SPL: käynnistys epäonnistui kaikilta käynnistyslaitteilta ### ERROR ### PALAUTA taulu ###
  4. Rockpi 4A v1.4 Armbian 20.11.1 Buster with Linux 5.9.11-rockchip64 Winbond 25Q64FVSIG...1516
  5. U-Boot TPL 2020.07-armbian (Nov 30 2020 - 18:39:44) Channel 0: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB Channel 1: LPDDR4, 50MHz BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB 256B stride 256B stride lpddr4_set_rate: change freq to 400000000 mhz 0, 1 lpddr4_set_rate: change freq to 800000000 mhz 1, 0 Trying to boot from BOOTROM Returning to boot ROM... U-Boot SPL 2020.07-armbian (Nov 30 2020 - 18:39:44 +0100) Trying to boot from MMC1 NOTICE: BL31: v1.3(debug):42583b6 NOTICE: BL31: Built : 07:55:13, Oct 15 2019 NOTICE: BL31: Rockchip release version: v1.1 INFO: GICv3 with legacy support detected. ARM GICV3 driver initialized in EL3 INFO: Using opteed sec cpu_context! INFO: boot cpu mask: 0 INFO: If lpddr4 need support multi frequency, INFO: please update loader! INFO: Current ctl index[0] freq=400MHz INFO: Current ctl index[1] freq=800MHz INFO: plat_rockchip_pmu_init(1190): pd status 3e INFO: BL31: Initializing runtime services WARNING: No OPTEE provided by BL2 boot loader, Booting device without OPTEE initialization. SMC`s destined for OPTEE will return SMC_UNK ERROR: Error initializing runtime service opteed_fast INFO: BL31: Preparing for EL3 exit to normal world INFO: Entry point address = 0x200000 INFO: SPSR = 0x3c9 U-Boot 2020.07-armbian (Nov 30 2020 - 18:39:44 +0100) SoC: Rockchip rk3399 Reset cause: POR Model: Radxa ROCK Pi 4B DRAM: 3.9 GiB PMIC: RK808 MMC: mmc@fe310000: 2, mmc@fe320000: 1, sdhci@fe330000: 0 Loading Environment from SPI Flash... unrecognized JEDEC id bytes: ef, 40, 17 *** Warning - spi_flash_probe_bus_cs() failed, using default environment In: serial Out: serial Err: serial Model: Radxa ROCK Pi 4B Net: eth0: ethernet@fe300000 Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc1 is current device Scanning mmc 1:1... Found U-Boot script /boot/boot.scr 3185 bytes read in 6 ms (517.6 KiB/s) ## Executing script at 00500000 Boot script loaded from mmc 1 251 bytes read in 4 ms (60.5 KiB/s) 13480044 bytes read in 579 ms (22.2 MiB/s) 27574784 bytes read in 1173 ms (22.4 MiB/s) 74167 bytes read in 12 ms (5.9 MiB/s) 1314 bytes read in 8 ms (160.2 KiB/s) Applying kernel provided DT overlay rockchip-spi-jedec-nor.dtbo 2698 bytes read in 8 ms (329.1 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) ## Executing script at 09000000 ## Loading init Ramdisk from Legacy Image at 06000000 ... Image Name: uInitrd Image Type: AArch64 Linux RAMDisk Image (gzip compressed) Data Size: 13479980 Bytes = 12.9 MiB Load Address: 00000000 Entry Point: 00000000 Verifying Checksum ... OK ## Flattened Device Tree blob at 01f00000 Booting using the fdt blob at 0x1f00000 Loading Ramdisk to f1237000, end f1f1202c ... OK Loading Device Tree to 00000000f11bc000, end 00000000f1236fff ... OK Starting kernel ...
  6. U-Boot SPL 2020.07-armbian (Nov 30 2020 - 18:39:44 +0100) Trying to boot from MMC1 Card did not respond to voltage select! spl: mmc init failed with error: -95 Trying to boot from MMC2 Card did not respond to voltage select! spl: mmc init failed with error: -95 SPL: failed to boot from all boot devices ### ERROR ### Please RESET the board ### i try with 7 nvme, also sdcard not boot
  7. Tested Rockpi4a v1.4 SPI U-Boot 2017.09-2686-g18c70dba63 (Dec 31 2019 - 12:33:07 +0000), Build: jenkins-linux-build-testing-2-136 this works, only flash img to nvme, do nothing armbianEnv.txt or boot.cmd, no sdcard Intel 660p Armbian_20.02.1_Rockpi-4a_buster_legacy_4.4.213.img ....................... Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x8086 Rev: 002C Prod: BTNH90820C73512A Type: Hard Disk Capacity: 488386.3 MB = 476.9 GB (1000215216 x 512) ... is now current device Scanning nvme 0:1... Found U-Boot script /boot/boot.scr 2940 bytes read in 5 ms (574.2 KiB/s) ## Executing script at 00500000 Boot script loaded from nvme 0 189 bytes read in 6 ms (30.3 KiB/s) 6758686 bytes read in 67 ms (96.2 MiB/s) 19752968 bytes read in 171 ms (110.2 MiB/s) 93124 bytes read in 23 ms (3.9 MiB/s) ** File not found /boot/dtb/rockchip/overlay/rockchip-fixup.scr ** ............................. Kingston 2000 and Gigabyte this works, armbianEnv.txt add fdtfile=rockchip/rk3399-rock-pi-4.dtb Armbian_20.02.7_Rockpi-4a_buster_current_5.4.28.img ................. Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x2646 Rev: S5Z42102 Prod: 50026B72823F1B89 Type: Hard Disk Capacity: 238475.1 MB = 232.8 GB (488397168 x 512) ... is now current device Scanning nvme 0:1... Found U-Boot script /boot/boot.scr 2940 bytes read in 4 ms (717.8 KiB/s) ## Executing script at 00500000 Boot script loaded from nvme 0 189 bytes read in 4 ms (45.9 KiB/s) 7287636 bytes read in 69 ms (100.7 MiB/s) 20787712 bytes read in 184 ms (107.7 MiB/s) 72736 bytes read in 11 ms (6.3 MiB/s) 2698 bytes read in 6 ms (438.5 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) ................................................................................ These NVME not works, tested , many scripts, there is errors kingston A1000 Armbian_20.02.7_Rockpi-4a_buster_current_5.4.28.img ................. Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x2646 Rev: E8FK11.R Prod: 50026B76826C0418 Type: Hard Disk Capacity: 228936.5 MB = 223.5 GB (468862128 x 512) ... is now current device Scanning nvme 0:1... Found U-Boot script /boot/boot.scr 2985 bytes read in 7 ms (416 KiB/s) ## Executing script at 00500000 Boot script loaded from nvme 0 189 bytes read in 5 ms (36.1 KiB/s) ERROR: status = 13, phase = 1, head = 1 ** fs_devread read error - block ERROR: status = 13, phase = 0, head = 1 ** fs_devread read error - block 72736 bytes read in 22 ms (3.2 MiB/s) 2698 bytes read in 10 ms (262.7 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) ................ PNY CS3030 250GB ......................... Armbian_20.02.7_Rockpi-4a_buster_current_5.4.28.img .................... Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x1987 Rev: CS303224 Prod: PNY35190025670102900 Type: Hard Disk Capacity: 238475.1 MB = 232.8 GB (488397168 x 512) ... is now current device Scanning nvme 0:1... Found U-Boot script /boot/boot.scr 2940 bytes read in 6 ms (478.5 KiB/s) ## Executing script at 00500000 Boot script loaded from nvme 0 189 bytes read in 5 ms (36.1 KiB/s) ERROR: status = 2013, phase = 1, head = 1 ** fs_devread read error - block ERROR: status = 2013, phase = 0, head = 1 ** fs_devread read error - block 72736 bytes read in 13 ms (5.3 MiB/s) 2698 bytes read in 11 ms (239.3 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) ............................... Samsung 970 EVOPlus Armbian_20.02.7_Rockpi-4a_buster_current_5.4.28.img .................... Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x144d Rev: 1B2QEXM7 Prod: S4EUNG0M122756V Type: Hard Disk Capacity: 238475.1 MB = 232.8 GB (488397168 x 512) ... is now current device Scanning nvme 0:1... Found U-Boot script /boot/boot.scr 2940 bytes read in 5 ms (574.2 KiB/s) ## Executing script at 00500000 Boot script loaded from nvme 0 189 bytes read in 3 ms (61.5 KiB/s) ERROR: status = 2013, phase = 1, head = 1 ** fs_devread read error - block ERROR: status = 2013, phase = 0, head = 1 ** fs_devread read error - block 72736 bytes read in 15 ms (4.6 MiB/s) 2698 bytes read in 7 ms (376 KiB/s) Applying kernel provided DT fixup script (rockchip-fixup.scr) .................................
  8. also PNY 250GB XLR8 CS3030 M.2 NVMe SSD-levy, PCIe Gen3 x4, 3500/1050 (Hynix) not start SPI works well with SDcard with Armbian
  9. can do many ways, here's one - first flash spi u-boot https://forum.radxa.com/t/spi-nvme-booting-beta/1306 - flash Armbian img DL https://dl.armbian.com/rockpi-4b/archive/ and extracxt http://www.7-zip.org/ and flash it to sdcard https://www.etcher.io/ - connect pin 23 and 25 together, put sdcard to rocpi , root, passwd 1234 - apt update - apt upgrade - wget https://dl.armbian.com/rockpi-4b/archive/Armbian_19.11.3_Rockpi-4b_buster_legacy_4.4.198.7z - 7z e armbian.com/rockpi-4b/archive/Armbian_19.11.3_Rockpi-4b_buster_legacy_4.4.198.7z - dd if=Armbian_19.11.3_Rockpi-4b_buster_legacy_4.4.198.img of=/dev/nvme0n1 bs=1M - e2fsck -f /dev/nvme0n1p1 reboot, wait 2-3 sek. and remove SDcard, when red led light again in "root" and passwd "1234"................. - apt update - apt upgrade - nano /boot/armbianEnv.txt - add "fdtfile=rockchip/rk3399-rockpi4b.dtb" if 4.4.198, if 5.x.x , add "fdtfile=rockchip/rk3399-rock-pi-4.dtb" ctrl + x .....y - remove connect pins 23, 25, - remove SDcard - reboot sorry my bad english what brand of nvme you have?
  10. something new has come, great Armbian_19.11.3_Rockpi-4b_buster_current_5.3.11.img and radxa official SPI 4b u-boot, Kingston A2000 M.2 2280 PCIe NVMe Gigabyte SSD M.2 2280 PCIe x2 Model:GP-GSM2NE8128GNTD XPG GAMMIX S5 PCIe Gen3x4 M.2 2280 512 Kingston 240GB A1000 SSD = PHISON PS5008-E8-10 Samsung 250GB 970 EVO Plus SSD-levy, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s Intel SSD 660p Model:SSDPEKNW512GB boot with nvme without uSD and mmc
  11. 4A V1.4model not boot SPI with ..4a.......4.4.198....img, ....4b.....img and ...4b-u-boot....works well all of them works fine with SDcard tested Kinston A2000 nvme (not work Raxda official)
  12. Yes, NEW Linux rockpi 4.4.198-rockchip64 boot fine SPI without SDcard (Kingston A2000 NVME), also Gigabyte SSD M.2 2280 PCIe x2
×
×
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines