atula

  • Content Count

    37
  • Joined

  • Last visited

About atula

  • Rank
    Advanced Member

Recent Profile Visitors

745 profile views
  1. Tested Rockpi4a v1.4 SPI U-Boot 2017.09-2686-g18c70dba63 (Dec 31 2019 - 12:33:07 +0000), Build: jenkins-linux-build-testing-2-136 this works, only flash img to nvme, do nothing armbianEnv.txt or boot.cmd, no sdcard Intel 660p Armbian_20.02.1_Rockpi-4a_buster_legacy_4.4.213.img ....................... Hit key to stop autoboot('CTRL+C'): 0 Device 0: RKPARM: Invalid parameter part table Vendor: 0x8086 Rev: 002C Prod: BTNH90820C73512A Type: Hard Disk Capacity: 488386.3 MB = 476.9 GB (1000215216 x 512) ... is now current device Sc
  2. also PNY 250GB XLR8 CS3030 M.2 NVMe SSD-levy, PCIe Gen3 x4, 3500/1050 (Hynix) not start SPI works well with SDcard with Armbian
  3. can do many ways, here's one - first flash spi u-boot https://forum.radxa.com/t/spi-nvme-booting-beta/1306 - flash Armbian img DL https://dl.armbian.com/rockpi-4b/archive/ and extracxt http://www.7-zip.org/ and flash it to sdcard https://www.etcher.io/ - connect pin 23 and 25 together, put sdcard to rocpi , root, passwd 1234 - apt update - apt upgrade - wget https://dl.armbian.com/rockpi-4b/archive/Armbian_19.11.3_Rockpi-4b_buster_legacy_4.4.198.7z - 7z e armbian.com/rockpi-4b/archive/Armbian_19.11.3_Rockpi-4b_buster_legacy_4.4.198.7z - dd if=Armbian
  4. something new has come, great Armbian_19.11.3_Rockpi-4b_buster_current_5.3.11.img and radxa official SPI 4b u-boot, Kingston A2000 M.2 2280 PCIe NVMe Gigabyte SSD M.2 2280 PCIe x2 Model:GP-GSM2NE8128GNTD XPG GAMMIX S5 PCIe Gen3x4 M.2 2280 512 Kingston 240GB A1000 SSD = PHISON PS5008-E8-10 Samsung 250GB 970 EVO Plus SSD-levy, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s Intel SSD 660p Model:SSDPEKNW512GB boot with nvme without uSD and mmc
  5. 4A V1.4model not boot SPI with ..4a.......4.4.198....img, ....4b.....img and ...4b-u-boot....works well all of them works fine with SDcard tested Kinston A2000 nvme (not work Raxda official)
  6. Yes, NEW Linux rockpi 4.4.198-rockchip64 boot fine SPI without SDcard (Kingston A2000 NVME), also Gigabyte SSD M.2 2280 PCIe x2
  7. try /etc/udev/rules.d/99-tty-dialout.rules SUBSYSTEM=="tty", KERNEL=="ttyUSB0", GROUP="dialout", MODE="0666" or /etc/udev/rules.d/99-instruments.rules //new file SUBSYSTEM=="tty", GROUP="dialout", MODE="0666" or like my i2c /lib/udev/rules.d/60-i2c-tools.rules SUBSYSTEM=="i2c-dev",KERNEL=="i2c-[0-9]*", GROUP="i2c", MODE="0660" //replace "0666"
  8. I tried this https://github.com/ayufan-rock64/linux-build/blob/master/recipes/flash-spi.md not boot without sdcard edit i haw tested 4 nwme, only one of them boot (Radxa official) SPI, Armbian doesn't recognize this disc , 3 Armbian buster SD boot
  9. atula

    Rock PI 4

    Debian Buster with Armbian Linux 4.4.184-rockchip64 Kingston 240GB A1000 SSD, Samsung 250GB 970 EVO Plus SSD-levy, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s, XPG GAMMIX S5 PCIe Gen3x4 M.2 2280 512 works not support Intel 512GB 660P 1500/1000 MB/s -SSD- M.2, not find it linaro-alip 4.4.154 works and boot Intel 512GB 660P 1500/1000 MB/s -SSD- M.2 from spi XPG GAMMIX S5 PCIe Gen3x4 M.2 2280 512 boot also spi but not stabile Samsung 250GB 970 EVO Plus SSD-, M.2 2280, PCIe 3.0 x4, NVMe, 3500/2300 MB/s, Kingston 240GB A1000 SSD not boot sp
  10. can anyone help me how to use uart2 PB0,PB1 and uart3 PG10,PG11 uart0 works PB9, PB10 all serialpots is enabled in xxx.dtb "okay" but not work edit: all uarts works now
  11. w1 works Armbian_5.83_Bananapim3_Debian_stretch_next_4.19.38.img @nkahl onewire@0 { compatible = "w1-gpio"; gpios = <&pio 4 4 0>; /* PE4 */ status = "okay"; };
  12. atula

    Rock PI 4

    serialport /dev/ttyS4 problem is boot. when reconnect tx cable or ds2480 pover after boot it works. problem is only armbian maybe on board SPI1 W25Q64F***.....?
  13. atula

    Rock PI 4

    Debian Buster with Armbian Linux 4.4.184-rockchip64 dev/ttyS2 , dev/ttyS4 not works, only read dev /ttyUSB0 woks fine root@rockpi:~# digitemp_DS9097U -i -s /dev/ttyS4 -c digitemp.conf DigiTemp v3.7.2 Copyright 1996-2018 by Brian C. Lane GNU General Public License v2.0 - http://www.digitemp.com Error 5: DS2480B Adapter Not Detected Error 10: Read COM Failed root@rockpi:~# digitemp_DS9097U -i -s /dev/ttyUSB0 -c digitemp.conf DigiTemp v3.7.2 Copyright 1996-2018 by Brian C. Lane GNU General Public License v2.0 - http://www.digitemp.com Turning of