stulluk

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. Hi, this is not a complaint, just wondering if I am doing something wrong. When I try "any(Pine64,Sopine,Olinuxino-A64,Bananapi-M64)" A64 board with armbian 3.10.x kernel, desktop performance is quite satisfactory. Example: https://dl.armbian.com/_old/pine64/archive/Armbian_5.90_Pine64_Ubuntu_xenial_default_3.10.107_desktop.7z But when I build armbian in docker, both 5.4 and 5.6 kernels, I experience dramatic slowdown on desktop performance, even cursor is moving slowly. Here are armbian monitor logs: http://ix.io/2oW4 and http://ix.io/2oVY Here is how it looks on BPI-m64 as an example: https://streamable.com/vy9tmh In both images, lima module is loaded and running. I know having GPU hardware acceleration with open source drivers are not on par with closed binaries, but I wasn't expecting this difference. Is it a known issue or am I doing something wrong ? If it is a known issue, can I build armbian with 3.10 (legacy) kernel ? Is there a guide for this?
  2. Any update on this topic ? Did anyone managed to run MPV with HW Video acceleration on 5.3+ Kernels from Armbian ?
  3. Dear All, Thank you so much for your efforts for such a nice project. I searched for the forum, but couldn't find a similar topic. I also checked the documentation, but couldn't find about "What are the steps for a new device" ? I have a new Allwinner A64 based SoM + Carrier based system, used for smart home. The board's name is DR47. A samples photo is below: Currently, latest Armbian SOPINE image (which I downloaded from here: https://dl.armbian.com/pine64so/nightly) works perfectly on my board, at least it boots without any errors, and my rtl8152 USB-Ethernet works too. I have studied "Building Armbian" , and setup vagrant, but failed to create image, because of below error: [ error ] ERROR in function compile_uboot [ compilation.sh:226 Anyway, my question is, how can I customise my build environment, so that I can build directly for DR47, not for SOPINE? What are the correct steps to add my own board to armbian build system? Because my board has a lot of differences, such as, it can drive 7" and 10.1" LVDS LCD ( not simultaneously of course ), and I want to customize my output to drive my LCD's ... Thanks for the replies.