w1nner4fun

Members
  • Content Count

    6
  • Joined

  • Last visited


Reputation Activity

  1. Like
    w1nner4fun reacted to manuti in MXQ Pro+ (plus) 4k Android 7.1.2, boot problem, probably lightdm   
    I can't remember all the options, but I think "armbian-config" has a switch to go directly to the Desktop or not.
    And "nodm" must be properly configured see: https://wiki.archlinux.org/index.php/Nodm
  2. Like
    w1nner4fun reacted to manuti in MXQ Pro+ (plus) 4k Android 7.1.2, boot problem, probably lightdm   
    These are my MXQ https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/
    Related to the performance of the OS, the system go quite well in my MXQ PRO PLUS (2GB RAM) but have micro freezes or hang for 1 second every minute in MXQ PRO (1GB RAM).
    I flashed Ubuntu Mate and Debian Server. But the image installed to the eMMC is Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz
    To install in the eMMC I use the option in armbian-config tool. You can launch from Terminal with: 
    sudo armbian-config I can't remember where it is exactly in the menu tree. Bear in mind when you choose to Install (install in SATA, NAND or something like this say the option) you lose the Android and the option don't ask for confirmations. 
     
    Kind regards.
  3. Like
    w1nner4fun reacted to manuti in MXQ Pro+ (plus) 4k Android 7.1.2, boot problem, probably lightdm   
    I have another MXQ Pro Plus 4K and works quite well.
    https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/
    I flashed finally Linux in eMMC memory. 
    Normally the system must start in graphic mode but asking for an user and password. 
    If you want to go straight to the Desktop you must install "nodm" ( sudo apt install nodm ) and maybe remove "lightdm". I don't have any flickering or video issues. 
    Regards 
  4. Like
    w1nner4fun got a reaction from manuti in MXQ Pro+ (plus) 4k Android 7.1.2, boot problem, probably lightdm   
    Hello,
    First, thanks everybody here for making this possible.
    Second, I am a newbie on booting Linux on TV box, so bear with me. Thanks.
    My problem:
    I have a MXQ Pro+ 4k (2GB RAM - 16GB storage - Android 7.1.2 - 64bit) box and have tried most of the recent images for x905s based TV boxes, following the instructions on the first page of this topic.
    I have a semi-workable result using Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180203, but still it is not really usable.
    I wrote this image to USB 3.0 stick and booted after updating via local update on Android.
    After setting user I can only access desktop after typing ctrl+alt+f1 -> login -> startx.
    The system doesn't login automatically and I get a lot of screen flickering with messages regarding lightdm and light desktop manager.
    What am I doing wrong? How do I get to desktop automatically? Can anyone help, please?
    (please ask if I didn't specify all the necessary details)
    Thanks.