3 3
w1nner4fun

MXQ Pro+ (plus) 4k Android 7.1.2, boot problem, probably lightdm

Recommended Posts

Hello,

First, thanks everybody here for making this possible.

Second, I am a newbie on booting Linux on TV box, so bear with me. Thanks.

My problem:

I have a MXQ Pro+ 4k (2GB RAM - 16GB storage - Android 7.1.2 - 64bit) box and have tried most of the recent images for x905s based TV boxes, following the instructions on the first page of this topic.

I have a semi-workable result using Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180203, but still it is not really usable.

I wrote this image to USB 3.0 stick and booted after updating via local update on Android.

After setting user I can only access desktop after typing ctrl+alt+f1 -> login -> startx.

The system doesn't login automatically and I get a lot of screen flickering with messages regarding lightdm and light desktop manager.

What am I doing wrong? How do I get to desktop automatically? Can anyone help, please?

(please ask if I didn't specify all the necessary details)

Thanks.

Edited by w1nner4fun

Share this post


Link to post
Share on other sites

I have another MXQ Pro Plus 4K and works quite well.

https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/

I flashed finally Linux in eMMC memory. 

Normally the system must start in graphic mode but asking for an user and password. 

If you want to go straight to the Desktop you must install "nodm" ( sudo apt install nodm ) and maybe remove "lightdm". I don't have any flickering or video issues. 

Regards 

Share this post


Link to post
Share on other sites
14 hours ago, manuti said:

I have another MXQ Pro Plus 4K and works quite well.

https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/

I flashed finally Linux in eMMC memory. 

Normally the system must start in graphic mode but asking for an user and password. 

If you want to go straight to the Desktop you must install "nodm" ( sudo apt install nodm ) and maybe remove "lightdm". I don't have any flickering or video issues. 

Regards 

Hi manuti, thanks for the fast response.

Can you tell me which image of linux you flashed on the MXQ Pro Plus 4K, please? Is it Armbian or something else?

Also, can you point me to the instructions for flashing into the eMMC, please?

Again, thank you very much for your help.

Share this post


Link to post
Share on other sites

These are my MXQ https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/

Related to the performance of the OS, the system go quite well in my MXQ PRO PLUS (2GB RAM) but have micro freezes or hang for 1 second every minute in MXQ PRO (1GB RAM).

I flashed Ubuntu Mate and Debian Server. But the image installed to the eMMC is Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz

To install in the eMMC I use the option in armbian-config tool. You can launch from Terminal with: 

sudo armbian-config

I can't remember where it is exactly in the menu tree. Bear in mind when you choose to Install (install in SATA, NAND or something like this say the option) you lose the Android and the option don't ask for confirmations

 

Kind regards.

Share this post


Link to post
Share on other sites
5 hours ago, manuti said:

These are my MXQ https://raspberryparatorpes.net/rivales/rivales-raspberry-pi-mxq-pro-4k-y-mxq-pro-plus/

Related to the performance of the OS, the system go quite well in my MXQ PRO PLUS (2GB RAM) but have micro freezes or hang for 1 second every minute in MXQ PRO (1GB RAM).

I flashed Ubuntu Mate and Debian Server. But the image installed to the eMMC is Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz

To install in the eMMC I use the option in armbian-config tool. You can launch from Terminal with: 


sudo armbian-config

I can't remember where it is exactly in the menu tree. Bear in mind when you choose to Install (install in SATA, NAND or something like this say the option) you lose the Android and the option don't ask for confirmations

 

Kind regards.

 

Thanks for pointing me to sudo armbian-config. I have discovered it yesterday and I will surely give it a go.

 

Regarding the lightdm: I have uninstalled it and the screen blinking/flickering is now gone. Thanks for that suggestion.

But I still cannot make the system go straight to the desktop, even if I have installed nodm as per your suggestion. Apparently the image I am using (Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180203) doesn't allow auto-login.

Hopefully I will find a solution soon.

Meanwhile I will try the image that you mention here and see if it's better. If so, I will flash it to the eMMC.

Thank you again.

 

 

Share this post


Link to post
Share on other sites
3 hours ago, manuti said:

I can't remember all the options, but I think "armbian-config" has a switch to go directly to the Desktop or not.

And "nodm" must be properly configured see: https://wiki.archlinux.org/index.php/Nodm

 

Yay, I have just installed nodm via armbian-config and it takes "root" user straight to the desktop. Nice! Thank you for pointing me to the right direction!

(I first tried the Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20171226.img.xz and it was behaving the same, so I reverted to Armbian_5.37_S9xxx_Ubuntu_xenial_3.14.29_mate_20180203 image)

So now it's working as it expected (without wifi though, only ethernet).

I only need some tool to backup the Android 7.1.2 (TWRP didn't work) and then install to eMMC. Do you know any method for a full backup of Android on this box?

(I've tried the method described here: https://forum.armbian.com/topic/2419-armbian-for-amlogic-s905-and-s905x/ but I get some error regarding the backup location-I still didn't figure out how to select SD card for backup)

 

 

Edited by w1nner4fun
added info

Share this post


Link to post
Share on other sites
On 15/03/2018 at 4:54 PM, w1nner4fun said:

I only need some tool to backup the Android 7.1.2 (TWRP didn't work) and then install to eMMC. Do you know any method for a full backup of Android on this box?

(I've tried the method described here: https://forum.armbian.com/topic/2419-armbian-for-amlogic-s905-and-s905x/ but I get some error regarding the backup location-I still didn't figure out how to select SD card for backup)

 

 

You can find the MXQ Pro + ROM here: https://chinagadgetsreviews.com/download-android-lollipop-5-1-1-stock-firmware-mxq-pro-tv-box-2-6.html

 

It will be necessary to use this software from Windows otherwise there will be a Key error: https://quickfileshare.org/LI/NEW_USB_Burning_Tool.zip
Software in Chinese, can be put in English:

 

This is not a back-up, but the flash of the Box which will then be with a factory configuration.

 

Share this post


Link to post
Share on other sites
20 hours ago, DDA said:

 

You can find the MXQ Pro + ROM here: https://chinagadgetsreviews.com/download-android-lollipop-5-1-1-stock-firmware-mxq-pro-tv-box-2-6.html

 

It will be necessary to use this software from Windows otherwise there will be a Key error: https://quickfileshare.org/LI/NEW_USB_Burning_Tool.zip
Software in Chinese, can be put in English:

 

This is not a back-up, but the flash of the Box which will then be with a factory configuration.

 

 

Hi DDA,

This is a workable solution, thanks for suggesting it.

The problem is that I didn't find yet a solution for acceptable/watchable playback of flash, Sopcast or Acestream video.

(see my comment on this topic here: https://forum.armbian.com/topic/2419-armbian-for-amlogic-s905-and-s905x/?page=48&tab=comments#comment-51509 )

Therefore I'll stick to Android until I find that solution.

Thank you, regards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
3 3