Jump to content
  • 0

[Nano Pi Neo Air] ethernet over OTG says usb0: link is not ready


jy824212
 Share

Question

Hi,

 

I am using Linux nanopiair 3.4.113-sun8i distribution on my Nano Pi Neo Air and trying to get the g_ether works.

 

After using modprobe g_ether and set up the network/interfaces 

auto usb0

    iface usb0

    inet static address 192.168.0.2

    netmask 255.255.255.0

 

then edit /etc/modprobe.d/g_ether.conf:

options g_ether host_addr= 06:7b:95:4c:59:d7

 

After reboot it shows:

 

[    6.868451] usb0: MAC 06:7b:95:4c:59:d7
[    6.868475] usb0: HOST MAC 5e:5b:65:8f:94:85
[   11.484526] systemd[1]: Found device /sys/subsystem/net/devices/usb0.
[   16.249726] ADDRCONF(NETDEV_UP): usb0: link is not ready

 

in this case my PC can not recognize the usb driver when I plug my nano Pi after I set up the DHCP server on the Nano Pi. 

 

I do not know if it relates to [   16.249726] ADDRCONF(NETDEV_UP): usb0: link is not ready

 

Edited by jy824212
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
3 hours ago, jy824212 said:
After using modprobe g_ether and set up the network/interfaces 

auto usb0

    iface usb0

    inet static address 192.168.0.2

    netmask 255.255.255.0

 

 

I do use it for my eth0 in this way:

 

iface eth0 inet static
address 192.168.6.23

 

so try :

 

auto usb0

iface usb0 inet static
address 192.168.0.2

netmask 255.255.255.0

 

what does

ifconfig

show as output

 

or

ifconfig usb0 up

 

Did you reboot after setting up /etc/network/interfaces?

Link to comment
Share on other sites

Search Before Posting!

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...