1 1
Daniel Andersen

linux headers missing modpost (linux-headers-dev-odroid)

Recommended Posts

Armbianmonitor:

I already saw similar posts on this herehere and here

It looks like the combination of Kernel and Kernel-Header 5.89.190617 again is not complete to build own modules. 

 

Based on the configure script: 

Quote

configure:39364: checking whether modules can be built
configure:39393: cp conftest.c conftest.h build && make modules -C /usr/src/linux-headers-5.1.11-odroidxu4 EXTRA_CFLAGS=-Werror -Wframe-larger-than=4096   M=/home/daniel/source/zfs/build
/bin/sh: 1: scripts/mod/modpost: not found
make[1]: *** [__modpost] Error 127
make: *** [modules] Error 2


 

Then I tried to check the headers:

Quote

root@odroidxu4:src/linux-headers-5.1.11-odroidxu4 ▒2df16141a*▒# make headers_check
make[1]: *** No rule to make target 'arch/arm/tools/syscall.tbl', needed by 'arch/arm/include/generated/uapi/asm/unistd-common.h'.  Stop.
arch/arm/Makefile:324: recipe for target 'archheaders' failed
make: *** [archheaders] Error 2


Since it was already a few times on the forum and sometime there was a new build created and it was fixed again, I would like to know if I just came over the same error again or if I did something wrong. 

 

cheers,

 

Daniel

Share this post


Link to post
Share on other sites
34 minutes ago, Daniel Andersen said:

again is not complete to build own modules. 


Stable builds = support is as is / best effort. Its also not possible to follow up with the quantity of issues that around. Armbian's few regulars can't fix problems that builds up upstream (www.kernel.org) after 1000+ people poke around a kernel. DEV nightly kernels = support does not exists and welcome to join and dive into the kernel sources, build script. Problem could be made in a kernel sources upstream or in the process of creating a header package ... our packaging patch. Perhaps something is changed and you will need to solve this ... if you need kernel headers with a kernel you want now.

Share this post


Link to post
Share on other sites

It tried on /usr/src/linux-headers-5.1.12-sunxi for olinuxino A20: same problem (/bin/sh: 1: scripts/mod/modpost: not found)

 

when I compiled modpost additionaly in headers:

 sudo make M=scripts/mod

I could compile my module, so somewhere mod is missing in the "make scripts" even it is listed as subdir ... anyhow it works, but it is not a fix..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1