1 1
martinayotte

Switching Rockchip64-DEV to 5.2.y ...

Recommended Posts

2 hours ago, Igor said:

I am working on rockchip -> 5.2

I did builds for RockPro64 and RockPi4B. The latest will need fix for DTB filename.

I've also done preliminary trial for OPi-RK3399 and NanoPCT4, this latest also needs tweak of DTB filename.

EDIT : For NanoPCT4, it doesn't boot with new DTB, searching for rootfs and get mmc errors, I'm using old 5.1.y DTB for now and will investigate latter.

EDIT2: Rock64 is fine without any glitch.

Share this post


Link to post
Share on other sites

I'm running a 5.2 build (self-built using Armbian build system) on a RockPro64. 

 

 I installed and used armbian-config to enable booting from SD with root on NVME.  Other than adding the pcie_rockchip_host and phy_rockchip_pcie modules to the initifamfs-tool/modules file and updating initramfs,  I made no major changes.  Currently I'm  running a disco desktop build just to play with it.

 

The one thing I find curious (and which I also have seen before on Ayufan's images)  is that it takes more that 30 seconds from getting the kernel starting message until the  login prompt comes up   I get no other messages on the serial interface during that time.   Does anyone know why that is happening?   

 

Has anyone tried mainline u-boot for this  recently?  It seems that it now includes support for this board--I haven't tried it yet, myself.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1