Sd card Copy = no boot



Recommended Posts

Dear all, 


My problem:

I've tried to Copy my current micro sd card(8go) to another one (32go)

Copy with a virtualbox (Ubuntu with the dd command to Copy the first card to the other one) , or with gparted (Copy and past)

But with all these methods the problem stay the same = no boot


Error message:
Gave up waiting for root file system device.
Common problems
- Boot args (cat proc/
- Check rootdelay (did the system wait long enough?)
- Missing modules (cat proc/modules: Is /dev)
ALERT UUID-16bb1d19-3ee3-119r-Be32-9920fr7d190a does not exist.
Dropping to a shell!


I'm not an expert with Linux so I don't know how can I resolve this problem. 


Can you help me ?
Thx in advance

Board: Cubox-i, Hummingboard / Gate & Edge
Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

1 hour ago, Pixou said:

Unfortunately the blkid command return nothing just after blkid I see the (initramfs)


With ls I don't see the boot folder but in my virtualbox I see the boot folder and the uuid is the same than the error

I mean you should do the "blkid" command in a shel of your virtualbox while SDCard reader inserted.

Check also /etc/fstab ...


Link to post
Share on other sites

Today I've tested a clone with Clonezilla and same problem. 

Output of blkid ?

The blkid command sent me the same uuid than the error message and the same as the original SDcard. (blkid command with the virtualbox)

I really don't understand What is the problem


I've change the uuid (partition uuid, fstab and inside armbian env.txt) and now same error but with the New uuid... 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.