Jump to content

Sd card Copy = no boot


Pixou
 Share

Recommended Posts

Dear all, 

 

My problem:

I've tried to Copy my current micro sd card(8go) to another one (32go)

Copy with a virtualbox (Ubuntu with the dd command to Copy the first card to the other one) , or with gparted (Copy and past)

But with all these methods the problem stay the same = no boot

 

Error message:
Gave up waiting for root file system device.
Common problems
- Boot args (cat proc/cnd.no)
- Check rootdelay (did the system wait long enough?)
- Missing modules (cat proc/modules: Is /dev)
ALERT UUID-16bb1d19-3ee3-119r-Be32-9920fr7d190a does not exist.
Dropping to a shell!
(initramfs)

 

I'm not an expert with Linux so I don't know how can I resolve this problem. 

 

Can you help me ?
Thx in advance

Board: Cubox-i, Hummingboard / Gate & Edge
Link to comment
Share on other sites

Order Armbian Linux merch!

1 hour ago, Pixou said:

ALERT UUID-16bb1d19-3ee3-119r-Be32-9920fr7d190a does not exist.

You have to have matching partition UUIDs in both /boot/armbianEnv.txt and /etc/fstab. To figure out what should be the UUID, check output of "blkid" command.

Link to comment
Share on other sites

Unfortunately the blkid command return nothing just after blkid I see the (initramfs)

 

With ls I don't see the boot folder but in my virtualbox I see the boot folder and the uuid is the same than the error

Link to comment
Share on other sites

1 hour ago, Pixou said:

Unfortunately the blkid command return nothing just after blkid I see the (initramfs)

 

With ls I don't see the boot folder but in my virtualbox I see the boot folder and the uuid is the same than the error

I mean you should do the "blkid" command in a shel of your virtualbox while SDCard reader inserted.

Check also /etc/fstab ...

 

Link to comment
Share on other sites

Today I've tested a clone with Clonezilla and same problem. 

Output of blkid ?

The blkid command sent me the same uuid than the error message and the same as the original SDcard. 

I really don't understand What is the problem

Link to comment
Share on other sites

Today I've tested a clone with Clonezilla and same problem. 

Output of blkid ?

The blkid command sent me the same uuid than the error message and the same as the original SDcard. (blkid command with the virtualbox)

I really don't understand What is the problem

 

I've change the uuid (partition uuid, fstab and inside armbian env.txt) and now same error but with the New uuid... 

Link to comment
Share on other sites

I have no idea why dd would not work, but as a workaround you could:
 

use Win32Diskimager to create an *.img file from your old sd card. 

Than use Win32DiskImager or Etcher to burn that file to the new sd card.

 

Worked good for me.

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...